Bug #10732 Set SQL_MODE to NULL gives garbled error message
Submitted: 19 May 2005 10:08 Modified: 24 Jun 2005 9:31
Reporter: Anders Karlsson Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0.4 OS:Microsoft Windows (Windows, Linux)
Assigned to: Sergei Glukhov CPU Architecture:Any

[19 May 2005 10:08] Anders Karlsson
Description:
Subject is self describing, together with the reproduction info.

How to repeat:
C:\>mysql
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 69 to server version: 5.0.4-beta-nt

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> set @@SQL_MODE=NULL;
ERROR 1231 (42000): Variable 'sql_mode' can't be set to the value of '╣!c'
mysql>
[19 May 2005 17:44] Alexander Keremidarski
mysql> set @@SQL_MODE=NULL;
ERROR 1231 (42000): Variable 'sql_mode' can't be set to the value of ''

Tested on Fedora Core 3 against
ChangeSet@1.1840.1.4, 2005-05-17 23:49:01+01:00, acurtis@xiphis.org
  fix embedded build
[19 May 2005 18:49] Anders Karlsson
Strange. I see it on 5.04 on both Windows and Linux (Fedora 2) and on 4.1.11. Also, the error message you get isn't correct either, as it says that SQL_MODE cannot be set to '' (the empty string), which really is an allowed value, i.e.:
SET @@SQL_MODE='';
work fine, and so it should. I see different values on different machines in the error message. There really is something slighly fishy here.
[19 May 2005 20:05] Sergei Golubchik
agree, Salle's result actually means "Verified" as error message incorrect
[23 May 2005 8:30] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/25171
[27 May 2005 18:04] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/25306
[9 Jun 2005 9:41] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/25803
[9 Jun 2005 10:02] Sergei Glukhov
Fixed in 4.1.13
[24 Jun 2005 3:25] Jon Stephens
1. Documented fix in 4.1.13 changelong.

2. I obtained the following results:

# mysql-5.0.7-beta-nt-max / Win2K Server - SP4:

mysql> SET @@SQL_MODE=NULL;
ERROR 1231 (42000): Variable 'sql_mode' can't be set to the value of 'pwl'
mysql> SET @@SQL_MODE='';
Query OK, 0 rows affected (0.00 sec)

# mysql-5.0.7-beta-standard / SuSE 9.2 - kernel 2.6.8-24.11-default

mysql> SET @@SQL_MODE=NULL;
ERROR 1231 (42000): Variable 'sql_mode' can't be set to the value of '�h'
mysql> SET @@SQL_MODE='';
Query OK, 0 rows affected (0.00 sec)

So I'm setting the status of this bug back to Open until fix is reported for 5.0 tree.
[24 Jun 2005 7:15] Sergei Glukhov
The fix is merged into 5.0.8.
[24 Jun 2005 9:31] Jon Stephens
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html

Additional info:

Bugfix noted in 5.0.8 changelog; bug closed. Thanks for checking on this for 5.0.