Bug #107206 MySQL Workbench removed from Ubuntu 22.04 (jammy) repositories
Submitted: 4 May 7:02 Modified: 9 Nov 8:58
Reporter: dark jasmines Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S1 (Critical)
Version: OS:Ubuntu (22.10)
Assigned to: Balasubramanian Kandasamy CPU Architecture:Any

[4 May 7:02] dark jasmines
Description:
Hi all,
after upgrading to Ubuntu 22.04 I noticed that mysql-workbench package was removed from my system (although it was installed before upgrading).
I searched for it but it is not in the official 22.04 repository.
I found also that third parties mysql ubuntu repositories (https://repo.mysql.com/apt/ubuntu/dists/) has not been upgraded to jammy.
I searched askubuntu and I only get a "try with the snap package" poor suggestion.
Can anyone give me info?
Thanks a lot.

How to repeat:
Just search in official Ubuntu repositories or browse https://repo.mysql.com/apt/ubuntu/dists/
[4 May 7:32] MySQL Verification Team
Hello!

Thank you for the report and feedback.

regards,
Umesh
[4 May 13:26] MySQL Verification Team
We do have some news for you .....

One of the next 8.0 releases, 8.0.30 or, 8.0.31 or 8.0.32 will be ported to the Debian that you are using. Exact release is not yet determined, so it would suffice if you would  just follow our download pages once per month .....
[10 May 6:21] dark jasmines
Still no candidate to install.
[11 May 12:37] MySQL Verification Team
Bug #107262 marked as duplicate of this one
[9 Jun 23:58] Ben Bariteau
Is there any ETA on when this will be resolved?
[20 Jun 13:39] dark jasmines
Embarassing...
[20 Jun 14:59] Balasubramanian Kandasamy
Thanks for the bug report.

We are working on the Workbench Ubuntu 22.04 builds.
[8 Jul 14:20] dark jasmines
Progress?
[12 Jul 14:37] Balasubramanian Kandasamy
We are waiting for the QA sign-off.
[13 Jul 9:22] Giles McCann
I find myself here after about 2-3 days of whack-a-mole on missing libraries trying to build mysql-workbench for an armhf sbc dev box >:o

nightmare!

..

On a brighter note, atleast i learnt the ins-n-outs of the cats backside when it comes to cmake / compiling /etc / etc .. you live n learn eh..
[13 Jul 9:54] Giles McCann
Not sure if it's worth mentioning but;

The build failed because of something along the lines of;

libmysqlcppconn.so: file not recognized: file format not recognized

-

After a bit of reading i think it has something to do with a mismatch/translation issue wherein (potentially multiple) variants of the libmysqlcppconn.so library are in use across different arch systems, causing symbols to be misinterpreted or w.e... trevoh..
[13 Jul 10:21] Giles McCann
.. You know when you have to build something, so you can build something else, that will then allow you to build the thing that lets you build what you wanted to build.. but then the final build doesnt build??? grr.
[21 Jul 9:23] dark jasmines
empire state building...
[26 Jul 10:18] Balasubramanian Kandasamy
MySQL Workbench 8.0.30 Ubuntu 22.04 packages are available now.

Thanks!
[25 Oct 10:33] dark jasmines
Removed again????
[2 Nov 11:11] dark jasmines
REOPEN!!!!
[9 Nov 8:58] dark jasmines
Now it has been removed from 22.10...