Bug #107176 Dual stack ubuntu group replication setup fails on add instance
Submitted: 2 May 10:24 Modified: 19 Jun 13:30
Reporter: Peter Doten Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Server: Group Replication Severity:S2 (Serious)
Version:8.0.28 OS:Ubuntu (20.04 LTS)
Assigned to: MySQL Verification Team CPU Architecture:Any

[2 May 10:24] Peter Doten
Description:
After creating Innodb cluster on Ubuntu primary node, set cluster variable via 
var cluster = dba.getCluster().
we see node working and is primary, see cluster working with one node.
Tried to add another node via
cluster.addInstance('clusteradmin@yournodeFQDNhere:3306') with valid FQDN. Operation times out with error 
Connection attempt from IP address ::ffff:x.x.x.x refused. Address is not in the IP whitelist.
The allow list is correct. group_replication_local_address is set properly, report_host is set properly in
/etc/mysql/mysql.conf.d/mysqld.cnf.  bind-address and mysqlx-bind-address are set to host IP address.

Tried to use IP address in addInstance command, no luck.
Did a netstat -tulpn on the OS, found the all GR ports are IPv6 with the exception of 33061. IPv6 is grabbing that one.

How to repeat:
Install Ubuntu 20.04 LTS on three VMs in different subnets.
-disable ufw
-disable selinux

Configure each node
1. mysqlsh --log-level=DEBUG3
2. dba.configureLocalInstance("root@localhost:3306");
	create clusteradmin account when asked
On all nodes
set values in /etc/mysql/mysql.conf.d/mysqld.cnf to allow access.
establish GR on one VM, try to add instance.

Suggested fix:
ensure that GR port binds to IPv6 if all others are bound to it.
[2 May 10:30] Peter Doten
Meant to state that GR ports are on IPv4 with the exception of 33061 which is on IPv6.
[19 May 13:30] MySQL Verification Team
Hi,

Please check whether the port that you specified is correct .....
[20 Jun 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".