Bug #106998 SSH connection - Unexpected problem
Submitted: 13 Apr 7:52 Modified: 8 Jun 12:31
Reporter: El Laf Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.28 Community OS:Windows
Assigned to: CPU Architecture:Any
Tags: login, ssh, SSH connection crash

[13 Apr 7:52] El Laf
Description:
I am unable to connect my database in AWS due to a ssh problem connection.

The log error is:

09:38:49 [INF][      SSHCommon]: libssh: ssh_pki_import_privkey_base64 ssh_pki_import_privkey_base64: Trying to decode privkey passphrase=true
09:38:49 [INF][      SSHCommon]: libssh: ssh_pki_openssh_import ssh_pki_openssh_import: Opening OpenSSH private key: ciphername: none, kdf: none, nkeys: 1
09:38:49 [ERR][      Workbench]: Un componente externo produjo una excepción.
Exception = System.Runtime.InteropServices.SEHException
Message = Un componente externo produjo una excepción.
FullText = System.Runtime.InteropServices.SEHException (0x80004005): Un componente externo produjo una excepción.
   en MySQL.Forms.ViewEventTarget.HandleMouseClick(Object sender, MouseEventArgs e)
   en System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   en System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   en System.Windows.Forms.Control.WndProc(Message& m)
   en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Each time I tried to connect my database
[17 May 9:51] André Cabaça
I'm having the same issue.

These are my configs:

Setup SSH hostname: the server's IP
SSH Username: my username on that machine
SSH Password: not configured
SSH Key File: my private key
Mysql hostname: tried both the hostname and the server's IP
Mysql Server Port: 3306
Username: My sql username
Password: not configured
Default Schema: my database name

I get the same error when I try to open a ssh remote management connection through workbench to other server that I can open SQL connection via workbench.

Hopefully this helps
[8 Jun 12:31] MySQL Verification Team
Hello,

Thank you for the bug report.
Imho this is duplicate of Bug #103905, please see Bug #103905.

Regards,
Ashwini Patil