Bug #106856 Wrong result from MySQL Shell for VS Code
Submitted: 28 Mar 14:55 Modified: 31 Mar 9:38
Reporter: Dave Stokes Email Updates:
Status: Closed Impact on me:
None 
Category:Shell VSCode Extension Severity:S2 (Serious)
Version:1.1.2 OS:Windows
Assigned to: Mike Zinner CPU Architecture:Any

[28 Mar 14:55] Dave Stokes
Description:
The query 

SELECT City.Name, Country.Name
FROM City
JOIN Country ON (City.CountryCode = Country.Code)
limit 7;

Returns the wrong result as the City.Name is not returned but is populated with the Country.Name values instead.

Name         Name
Aruba        Aruba
Afghanistan  Afghanistan
Afghanistan  Afghanistan
Afghanistan  Afghanistan
Angola       Angola
Angola       Angola

How to repeat:
1. Connect with MySQL Shell for VS Code to instance with world database installed.
2. issue query:
SELECT City.Name, Country.Name
FROM City
JOIN Country ON (City.CountryCode = Country.Code)
limit 7;
3. Examine result.
[28 Mar 14:56] Dave Stokes
Note that 
SELECT City.Name, Country.Name
FROM City
JOIN Country ON (City.CountryCode = Country.Code)
limit 7;

Works correctly
[28 Mar 16:00] MySQL Verification Team
Hello Dave,

Thank you for the report and feedback.

regards,
Umesh
[31 Mar 9:38] Mike Zinner
Hi Dave,

thanks a ton for that bug report! It was caused by the internal JSON structures we use for displaying the data in the result grid. The grid expects using the column caption as the key - which breaks if there are duplicate captions.

I have now published a fix for this in 1.1.3 that adds a count indicator to the column captions in the grid for duplicate names. Sorry about the delay, I am on vacation this week and the team is out sick with the flu...

Example: 
SELECT 1 as col, 2 as col, 3 as col, 4 as name, 5 as name, 6 as 'name (2)';

Again, thanks for the bug report - and please keep those bug reports coming! They help a lot to get the PREVIEW release stable.

Thanks,
Mike