Bug #106821 Data Export Wizard Not Visible
Submitted: 24 Mar 14:25 Modified: 30 Mar 12:46
Reporter: Judy Luke Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.28 OS:Ubuntu
Assigned to: CPU Architecture:Any
Tags: error log

[24 Mar 14:25] Judy Luke
Description:
When I click on server, Data Export, the wizard is missing. When clicking on advanced options I get:
MySQL error Unhandled exception: <weakref at 0x7fa1dc544180; to 'Administrator tab' at 0x7fa1cefb9b20>returnetd a result with an error set
I am using Ubuntu Linux and upgraded MySQL workbench to 8.0.28, which did not fix the problem.
Note that the Data Import Wizard is visible. The individual table data export works. 

How to repeat:
I keep on trying using the menu, server, Data export, and the wizard is missing. I already spent 8 hours trying to figure this out and this data is my job. Thank you.
[24 Mar 21:47] Judy Luke
Unhandled exception: WbAdminExport object has no attribute options_tab
[29 Mar 12:27] MySQL Verification Team
Hello Judy Luke,

Thank you for the bug report.
Could you please provide screenshot and error log file? Thanks.

Regards,
Ashwini Patil
[29 Mar 16:45] Judy Luke
I resolved the issue myself by uninstalling 

sudo snap remove mysql-workbench-community

and installing the newest version of mysql-workbench-community using the GDebi Package Installer. 

The error messages pointed to Snap mysql-workbench-community. Using the process of elimination, it had to be somehow caused by Snap.
[30 Mar 4:49] MySQL Verification Team
Hello Judy Luke,

Thank you for confirming that issue is no longer seen after re-installing.
Closing the report for now.

Regards,
Ashwini Patil
[30 Mar 12:46] Judy Luke
Just to be clear. re-installing MySQL workbench alone does not fix the problem. I tried that more than 10 times and the problem persisted. 
In Ubuntu Linux the snap MySQL workbench needs to be purged first, command line:
sudo snap remove mysql-workbench-community
Only after that, MySQL workbench can be installed without conflicts.