Bug #10681 Installation error (possibly help creation?)
Submitted: 17 May 2005 9:14 Modified: 25 May 2005 2:42
Reporter: Dino Tsoumakis Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:4.1.12 OS:Linux (SuSE 8.1 (2.4.21, i686))
Assigned to: CPU Architecture:Any

[17 May 2005 9:14] Dino Tsoumakis
Description:
When updating from 4.1.11 to 4.1.12 I got the following error. I tried this on 2 different systems both running with same configurations (both have 2 processors and 2GB RAM).

------------><---------------
lx180:/tmp/MySQL-4.1.12 # rpm -Uvh *.rpm
MySQL-client                ##################################################
MySQL-devel                 ##################################################
Giving mysqld a couple of seconds to exit nicely
MySQL-server                ##################################################
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1065  Query was empty
ERROR: 1036  Table 'help_topic' is read only
ERROR: 1036  Table 'help_topic' is read only
ERROR: 1036  Table 'help_category' is read only
ERROR: 1036  Table 'help_category' is read only
ERROR: 1036  Table 'help_keyword' is read only
ERROR: 1036  Table 'help_keyword' is read only
ERROR: 1036  Table 'help_relation' is read only
ERROR: 1036  Table 'help_relation' is read only
ERROR: 1065  Query was empty
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=134217728
read_buffer_size=2093056
max_used_connections=0
max_connections=200
threads_connected=1
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 949470 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0x85d7190
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xbff5ecd8, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
0x808df77
0x82e8af8
0x808c1e8
0x8084834
0x80b4c0e
0x80a2c14
0x809c69e
0x82e62ac
0x830fc3a
New value of fp=(nil) failed sanity check, terminating stack trace!
Please read http://dev.mysql.com/doc/mysql/en/Using_stack_trace.html and follow instructions on how to resolve the stack trace. Resolved
stack trace is much more helpful in diagnosing the problem, so please do
resolve it
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 0x85f28c0 = insert into help_category (help_category_id,name,parent_category_id) values (0,"Polygon properties",24),(1,"Column Types",15),(2,"Geometry constructors",24),(3,"WKT",24),(4,"Numeric Functions",22),(5,"GeometryCollection properties",24),(6,"Data Manipulation",15),(7,"Administration",15),(8,"MBR",24),(9,"Control flow functions",22),(10,"Transactions",15),(11,"Geometry relations",24),(12,"Functions and Modifiers for Use with GROUP BY Clauses",22),(13,"WKB",24),(14,"Date and Time Functions",22)
thd->thread_id=1
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.

WARNING: HELP FILES ARE NOT COMPLETELY INSTALLED!
The "HELP" command might not work properly

PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
To do so, start the server, then issue the following commands:
/usr/bin/mysqladmin -u root password 'new-password'
/usr/bin/mysqladmin -u root -h sigoslx180 password 'new-password'
See the manual for more instructions.

NOTE:  If you are upgrading from a MySQL <= 3.22.10 you should run
the /usr/bin/mysql_fix_privilege_tables. Otherwise you will not be
able to use the new GRANT command!

Please report any problems with the /usr/bin/mysqlbug script!

The latest information about MySQL is available on the web at
http://www.mysql.com
Support MySQL by buying support/licenses at https://order.mysql.com
Starting MySQL..done
MySQL-shared                ##################################################
lx180:/tmp/MySQL-4.1.12 #
------------><------------

Stack trace shows up:
------------><-----------
lx180:/tmp/MySQL-4.1.12 # resolve_stack_dump -s mysqld.sym -n mysqld.stack
0x808df77 handle_segfault + 423
0x82e8af8 pthread_sighandler + 184
0x808c1e8 copy_and_convert__FPcUiP15charset_info_stPCcUiT2PUi + 56
0x8084834 convert_string__3THDP13st_lex_stringP15charset_info_stPCcUiT2 + 84
0x80b4c0e yyparse__FPv + 63214
0x80a2c14 mysql_parse__FP3THDPcUi + 68
0x809c69e handle_bootstrap + 942
0x82e62ac pthread_start_thread + 220
0x830fc3a thread_start + 4
-----------><----------------

MySQL keeps crashing with same stack trace.

How to repeat:
Upgrade from 4.1.11 to 4.1.12 on SuSE Linux 8.1 (2.4.21, i686). 
MySQL Grant tables have not been updated to new password format, because of old clients still in use.

my.cnf is as follows:
-----------><-----------------
[mysqld]
port              = 3306
socket          = /var/lib/mysql/mysql.sock
datadir   = /var/lib/mysql
server-id       = 1
skip-locking
skip-innodb
max_connections      = 200

### Caches and Buffer Sizes
key_buffer_size         = 128M
max_allowed_packet      = 1M
sort_buffer_size        = 2M
read_buffer_size        = 2M
join_buffer_size        = 1M
table_cache             = 128
myisam_sort_buffer_size = 16M
thread_cache            = 16
thread_stack            = 128K

[mysqld_safe]
log-error=/var/lib/mysql/mysqld.log

[isamchk]
key_buffer_size   = 256M
sort_buffer_size  = 256M
read_buffer_size  = 16M
write_buffer_size = 16M

[myisamchk]
key_buffer_size   = 256M
sort_buffer_size  = 256M
read_buffer_size  = 16M
write_buffer_size = 16M

[mysqlhotcopy]
interactive-timeout

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
-----------><-----------------

Suggested fix:
?
[23 May 2005 7:58] Dino Tsoumakis
Seems to be fixed in latest RPM build version (4.1.12-1).
[25 May 2005 2:42] Miguel Solorzano
Thank you for the Info.
[25 May 2005 14:24] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/25264
[27 May 2005 19:07] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/25346