Bug #10674 4.1.11 => 4.1.12 Crash with signal 11
Submitted: 16 May 2005 15:28 Modified: 9 Jun 2005 20:37
Reporter: Matt Siemens Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.1.12 OS:Linux (Fedora Core 3)
Assigned to:

[16 May 2005 15:28] Matt Siemens
Description:
I just built the 4.1.12 release from the source RPM to update our DB server running 4.1.11 (also built from the source RPM).  Upon running a "rpm -Uvh" for the server package, I get the following error message:

===<error>===
050516 10:29:00  InnoDB: Started; log sequence number 0 43654
mysqld: ready for connections.
Version: '4.1.12-standard-log'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MySQL Community Edition - Standard (GPL)
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=402653184
read_buffer_size=2093056
max_used_connections=1
max_connections=10240
threads_connected=1
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 352176 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0x8a38528
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xbe7fea08, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
0x80a85a6
0x8302a0c
0x80a5d74
0x809c328
0x80cc6d1
0x80bf526
0x80bfc8a
0x80c09df
0x80c1052
0x82fd349
0x832d19a
New value of fp=(nil) failed sanity check, terminating stack trace!
Please read http://dev.mysql.com/doc/mysql/en/Using_stack_trace.html and follow instructions on how to resolve the stack trace. Resolved
stack trace is much more helpful in diagnosing the problem, so please do
resolve it
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 0x8a3d668 = select albumName from cwftable_album where albumIndex = 'stag'
thd->thread_id=1
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.
===</error>===

I ran "myisamchk --silent --force */*.MYI" to ensure that all index files are in order - no problems there.  Resolving the symbols in the above error message, with the command "resolve_stack_dump -s mysqld.sym -n mysql.stack" provides the following information:

===<stack_dump>===
0x80a85a6 handle_segfault + 610
0x8302a0c __pthread_sighandler + 144
0x80a5d74 _Z16copy_and_convertPcjP15charset_info_stPKcjS1_Pj + 52
0x809c328 _ZN3THD14convert_stringEP13st_lex_stringP15charset_info_stPKcjS3_ + 100
0x80cc6d1 _Z7yyparsePv + 43387
0x80bf526 _Z11mysql_parseP3THDPcj + 84
0x80bfc8a _Z16dispatch_command19enum_server_commandP3THDPcj + 1692
0x80c09df _Z10do_commandP3THD + 127
0x80c1052 handle_one_connection + 1418
0x82fd349 pthread_start_thread + 201
0x832d19a clone + 106
===</stack_dump>===

I've reverted back to 4.1.11 for now, which seems to be working just fine.

How to repeat:
Build and install MySQL 4.1.11 from source RPM (client, server and devel packages) on Fedora Core 3 (with all system updates applied).  Started MySQL (service mysql start).  Build 4.1.12 release from source RPM and upgrade client, server and devel packages.
[18 May 2005 22:45] Nathan Miller
Confirmed this exact same problem on FC2 as well.

Also, same problem on 4.1.12 binaries as well as source.
[20 May 2005 11:46] Willi Zinser
Same occurs on SuSe 9.2 Professional
[25 May 2005 3:00] Miguel Solorzano
If you have installed the RPM package 4.1.12 (which had problems)
please test with the today package 4.1.12-1.

Thanks in advance.
[25 May 2005 15:02] Matt Siemens
Miguel,

I've installed 4.1.12-1 in our staging environment and it looks like it's running well.  Thanks for the quick fix on this. I'll keep an eye on things over the next few days just to be sure everything's cool, but at this point, it looks like we're in good shape.

--Matt