Bug #106674 Installation of MySQL ODBC 8.0 on Macbook M1 Windows 11 fails
Submitted: 8 Mar 15:04 Modified: 25 May 14:38
Reporter: Roland Giesler Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:8.0.28 OS:Windows (v11 64bit)
Assigned to: CPU Architecture:ARM
Tags: arm, mac M1, ODBC 8, Windows 64bit

[8 Mar 15:04] Roland Giesler
Description:
Windows 11 ARM architecture is running in Parallels on a Macbook M1.

To install this ODBC driver the VC++2019 runtime libraries need to be installed first.  There's is an ARM version of these available at https://aka.ms/vs/17/release/vc_redist.arm64.exe.  After installation of these and restarting the windows 11 instance, the installation of ODBC 8.0.28 or earlier versions of the 8.0 drivers fails with the following error.

"Error 1918. Error installing ODBC driver MySQL ODBC 8.0 ANSI Driver, ODBC error 13: The setup routines for the MySQL ODBC 8.0 ANSI Driver ODBC drive could not be loaded due to system error code 193: .. Verify that the file MySQL ODBC 8.0 ANSI Driver exists and the you c..." 

The text is cut off after the c... 

How to repeat:
As above.
[25 May 12:16] MySQL Verification Team
Hello Roland Giesler,

Thank you for the bug report.
Imho this is duplicate of Bug #106439, please see Bug #106439 and follow suggested fix.

Regards,
Ashwini Patil
[25 May 14:38] Roland Giesler
I'm not sure why this is considered a duplicate.  The error I get is 193 and the message is different from the one in the other bugreport (https://bugs.mysql.com/bug.php?id=106439)

I'm reasonably sure this is not the same problem.  I don't see the behaviour described in issue #106439.

I will recheck this on the machine (which is not with me, so I'll have to arrange access)