Bug #106530 The MySQL80 service on Local Computer started and then stopped and cant create l
Submitted: 21 Feb 16:57 Modified: 23 Feb 16:39
Reporter: Hugo Pereira Oliveira Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.0 OS:Windows
Assigned to: CPU Architecture:x86

[21 Feb 16:57] Hugo Pereira Oliveira
Description:
When I try to start the MySQL80 service it gives the following warning "The MySQL57 service on Local Computer started and then stopped and cant create local file". When reading answers on the forum, I came to the conclusion that the problem may be this:

in the directory: C:\Program Files\MySQL\MySQL Server 8.0\bin when using the command: mysqld --initialize --console

I get the following error:

2022-02-20T20:38:43.800979Z 0 [System] [MY-013169] [Server] C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe (mysqld 8.0.28) initializing of server in progress as process 6148 2022-02-20T20:38:43.818861Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started. 2022-02-20T20:38:43.822839Z 1 [ERROR] [MY-012576] [InnoDB] Unable to create temporary file inside "C:\Users\Public\Documents\Wondershare\CreatorTemp"; error: 2 2022-02-20T20:38:43.822946Z 1 [ERROR] [MY-012929] [InnoDB] InnoDB Database creation was aborted with error Generic error. You may need to delete the ibdata1 file before trying to start up again. 2022-02-20T20:38:43.823742Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed. 2022-02-20T20:38:43.823838Z 0 [ERROR] [MY-013455] [Server] The newly created data directory C:\Program Files\MySQL\MySQL Server 8.0\data\ by --initialize is unusable. You can remove it. 2022-02-20T20:38:43.824250Z 0 [ERROR] [MY-010119] [Server] Aborting 2022-02-20T20:38:43.824822Z 0 [System] [MY-010910] [Server] C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe: Shutdown complete (mysqld 8.0.28) MySQL Community Server - GPL.

How to repeat:
I don't know, it seems that it is some bug in the system to access the folder "C:\Users\Public\Documents\Wondershare\CreateTemp" or something related to the password, because when trying to log into the bin folder through mysqld with the command "mysql - u admin -p" when entering my password I received this error "ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)." Also unable to start "MySQL" service

Suggested fix:
in my case, I had to downgrade the sql server to version 5.7. It took 4 days of trying and that was the only solution, which makes me think it's a bug with version 8.0
[23 Feb 16:39] MySQL Verification Team
Hello,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with MySQL Server 8.0.28 and tried to run mysqld --initialize --console from bin folder and restarted the server without any errors.
If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.  

Thank you for your interest in MySQL.

Regards,
Ashwini Patil