Bug #106387 Trace for Z/OS connection error
Submitted: 6 Feb 23:12 Modified: 9 Feb 9:59
Reporter: D Hughes Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connector / J Severity:S3 (Non-critical)
Version:8.0 OS:Other
Assigned to: CPU Architecture:Other (Z/OS)

[6 Feb 23:12] D Hughes
Description:
Trace file for Forum report https://forums.mysql.com/read.php?39,701665,701665#msg-701665

Attached is a WireShark file showing the error.  Lines 1-14 are trying to connect from Z/OS, line 15+ are for the same application connecting from a Windows system.
In this case the target sever is a MariaDB because that is the system with WireShark, but I get the same results when the target system is a MySQL server.

How to repeat:
Try to connect to a MySQL server running on Windows from an application running on IBM's Z/OS.
[6 Feb 23:13] D Hughes
Wireshare capture

Attachment: DriverTest.pcapng (application/octet-stream, text), 7.52 KiB.

[7 Feb 5:06] MySQL Verification Team
Thank you for the report and feedback.
[9 Feb 9:59] Filipe Silva
Resolved after setting default encodings in Java to UTF-8 using -Dfile.encoding=UTF-8.