Bug #106275 Mysql 8.0.28 More than 20 Times slower than MYSQL 8.0.27
Submitted: 25 Jan 11:28 Modified: 28 Jan 14:27
Reporter: muhindi karua Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.0.28 OS:Windows (10)
Assigned to: CPU Architecture:Any
Tags: Drop, MySQL, Perfomance

[25 Jan 11:28] muhindi karua
Description:
I installed Mysql 8.0.28 on my computer and imported data from a previous MYSQL 8.0.27 Installation. 

a query That takes 0.3s on MySQL 8.0.27 takes more than 22s on MySQL 8.0.28,

Tried on several computers with different architectures and the results are the same.

How to repeat:
create a database with MySQL 8.0.27 and run a query with several joins 

try running the query on the same DB different MySQL installation 8.0.28
[25 Jan 14:30] MySQL Verification Team
Hi Mr. karua,

Thank you for your bug report.

However, we can not proceed with further processing of your report.

We simply need a fully repeatable test case, which includes dumps of all the tables involved, as well as the full query itself. Without those, we can not proceed.

We are waiting on your full feedback with all the data that we asked for.
[26 Jan 9:11] muhindi karua
The query am trying to run is 

SELECT * FROM finance_fees_statementv WHERE AdmNo like '11854';

takes less than a second on MySQL 8.0.27 AND More than 20s on MySQL 8.0.28
[26 Jan 9:13] muhindi karua
File Attached
[26 Jan 14:51] MySQL Verification Team
Hi Mr. karua,

Unfortunately, we can not repeat your test case, since we are missing your table named `school_trackstudents`.

Please send us that table, plus all the others that we are missing for this test .......
[26 Jan 15:39] muhindi karua
Uploaded a different file mysql-bug-data-106275.zip via SFTP.
[27 Jan 14:10] MySQL Verification Team
Also,

Please let us know in which directory have you uploaded it ????
[27 Jan 14:12] MySQL Verification Team
Hi, 

Are you sure it contains all the tables and in the correct order ???

We shall  try to use it, never the less, if we find it  .....
[27 Jan 14:23] MySQL Verification Team
Hi Mr. karua,

We have looked at both support and incoming directories and all others that we have access to and we can not file by that name.

Please, use instead "Files" tab to upload that file !!!!!

Thanks in advance ......
[27 Jan 14:38] muhindi karua
The file is larger than 3MB
I apploaded the file to sftp.oracle.com:/support/incoming
the file name is 
mysql-bug-data-106275.zip

I uploaded again as mysql-bug-data-106275-1.zip
[27 Jan 14:57] MySQL Verification Team
Hi Mr. karua,

We have some problems with our SFTP site, so we have to resolve those first ......
[28 Jan 14:06] MySQL Verification Team
Hi,

These are the mean values for 8.0.27, with three runs:

real	0m1.418s
user	0m0.013s
sys	0m0.007s

After I do all other preparatory work,  I will report the values for 8.0.28.
[28 Jan 14:27] MySQL Verification Team
Hi Mr. Karua,

These are the mean values from three runs by 8.0.28:

real	0m1.554s
user	0m0.012s
sys	0m0.007s

As you can see those are all identical.

You probably had another process running (like antivirus) while you were running 8.0.28.

Not a bug.