Bug #106235 Unable to Relink MySQL Tables Following ODBC Upgrade from 5.3 to 8.0
Submitted: 21 Jan 12:30 Modified: 21 Jan 13:52
Reporter: John Randall Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:v8.0.28 OS:Windows (Windows 10 Pro)
Assigned to: CPU Architecture:x86

[21 Jan 12:30] John Randall
Description:
We have a database application consisting of an MS Access 365 on Windows frontend and two MySQL v5.6 Backend Database Servers running on Windows Server (x64).

The application works perfectly using the ODBC Connector v5.3.2 but if we upgrade it to the latest version (v8.0.29), the relinking of the tables from the old connector to the new connector fails for every table with the inexplicable error message: "Cannot define field more than once." 

The error message is displayed when using both our own VBA code and when using the Access Linked Table Manager. When using VBA, the associated error code is -2147467259

The problem is repeatable with both the x86 and x64 versions of the ODBC connector on Windows 10 / Access 365 x86 and on Windows 11 / Access 365 x64.

The problem can be resolved by uninstalling the connector and reinstalling v5.3.2 of the connector.

We have created a Trace log which we are happy to supply.

How to repeat:
The problem is repeatable by Installing the latest version v8.0.29 of the ODBC connector on a client Windows system and then using the Linked Table Manager in Microsoft Access 365 to link to a table within a MySQL 5.6 database.
[21 Jan 13:52] MySQL Verification Team
Hello John Randall,

Thank you for the bug report.
Imho this is duplicate of Bug #106204, please see Bug #106204.

Regards,
Ashwini Patil