Bug #106211 MySQL Workbench unhandled exception showing Client Connections
Submitted: 19 Jan 11:05 Modified: 19 Jan 12:36
Reporter: Richard Browne Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.27 OS:Windows
Assigned to: CPU Architecture:x86

[19 Jan 11:05] Richard Browne
Description:
Client Connections in MySQL Workbench gives unhandled exception.

How to repeat:
I run MySQL Workbench. In Administration tab, I click on Client Connections - Refresh. I get an Unhandled exception.

Log file shows:

21:54:01 [WRN][wb_admin_control.py:exec_query:623]: Error executing query SHOW GLOBAL STATUS: Error executing 'SHOW GLOBAL STATUS'
Lost connection to MySQL server during query.
SQL Error: 2013
21:54:01 [WRN][wb_admin_control.py:exec_query:625]: exec_query: Loss of connection to mysql server was detected.
21:54:01 [WRN][wb_admin_control.py:handle_sql_disconnection:672]: Error is recoverable. Reconnecting to MySQL server.
21:54:01 [ERR][       pymforms]: Unhandled exception in Python code: 
21:56:08 [ERR][wb_admin_utils.py:page_activated:352]: Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Unhandled exception in Python code: 
21:56:18 [ERR][       pymforms]: Unhandled exception in Python code: 
21:57:03 [ERR][         python]: Error forwarding notification to Python
Traceback:
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\workbench\notifications.py", line 35, in _the_observer
            for obs, nam, obj in self.observers:
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\Python\Lib\traceback.py", line 121, in format_exception
            type(value), value, tb, limit=limit).format(chain=chain))
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\Python\Lib\traceback.py", line 476, in __init__
            if (exc_value and exc_value.__cause__ is not None
NameError: 'str' object has no attribute '__cause__'
21:57:12 [WRN][         mforms]: Resource file not found: mysql-logo-80.png
21:57:13 [WRN][         mforms]: Resource file not found: mysql-logo-80.png
21:57:26 [ERR][wb_admin_utils.py:page_activated:352]: Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Unhandled exception in Python code: 
22:01:59 [ERR][wb_admin_utils.py:page_activated:352]: Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Exception activating the page - DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'Unhandled exception in Python code:
[19 Jan 12:20] MySQL Verification Team
Hello Richard Browne,

Thank you for the bug report.
Imho this is duplicate of Bug #102465, please see Bug #102465.

Regards,
Ashwini Patil
[19 Jan 12:36] Richard Browne
Ok thanks for the reply. Perhaps it is a duplicate. Will it be fixed? We just want to see the client connections in mysql workbench.