Bug #105462 Workbench 8.0.27 on Windows no longer allows Use SSL = 'No' or 'If required'
Submitted: 4 Nov 2021 18:19 Modified: 3 Dec 2021 20:46
Reporter: Russ Bubley Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.27 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[4 Nov 2021 18:19] Russ Bubley
Description:
On the connection (Standard TCP/IP) pop-up, on the SSL
tab, there are no longer any options to use without SSL.

How to repeat:
Create a connection to a local mysql instance, and attempt to connect to it without SSL.

Suggested fix:
Workaround on Stackoverflow: https://stackoverflow.com/a/69810181/3796914
[5 Nov 2021 12:19] MySQL Verification Team
Thank you for the bug report.
[13 Nov 2021 12:37] shoujun li
I think this one is duplicate of https://bugs.mysql.com/bug.php?id=105327
[3 Dec 2021 20:46] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.28 release, and here's the proposed changelog entry from the documentation team:

Before MySQL Workbench 8.0.27, a connection using SSL attempted to
establish an encrypted connection by default if the server supported
encrypted connections or to fall back to an unencrypted connection if an
encrypted connection could not be established. The default behavior was
changed in version 8.0.27 to always require SSL encryption, which could
cause a connection test to fail if the server did not support encryption.
In addition, the settable values for the Use SSL field no longer included
No or If available. 

This fix restores the previous default behavior (If
available) and also restores the full set of Use SSL values for
establishing encrypted and unencrypted connections.

Thank you for the bug report.