Bug #105217 dyld: Library not loaded: @executable_path/../Frameworks/libmysqlclient.dylib
Submitted: 13 Oct 22:55 Modified: 19 Oct 12:40
Reporter: Cesar Ramos Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Migration Severity:S3 (Non-critical)
Version:8.0.26 OS:Mac OS X (11.6)
Assigned to: CPU Architecture:x86 (i7)
Tags: Migrate schema

[13 Oct 22:55] Cesar Ramos
Description:
In a fresh mac
fresh workbench installation
No mysql installed

I try to execute menu->databases->migration wizard
(it used to work with my old mac)

everything goes well until STEP BULK DATA TRANSFER where I get this error:

-------------------
dyld: Library not loaded: @executable_path/../Frameworks/libmysqlclient.dylib
  Referenced from: /Applications/MySQLWorkbench.app/Contents/MacOS/wbcopytables
  Reason: no suitable image found.  Did find:
	file system relative paths not allowed in hardened programs

ERROR: Determine number of rows to copy: Error getting row count from source tables, wbcopytables exited with code -6
Failed
-------------------

when the system is executing this:

Starting...
Prepare information for data copy...
Prepare information for data copy done
Determine number of rows to copy....
Counting number of rows in tables...
/Applications/MySQLWorkbench.app/Contents/MacOS/wbcopytables --count-only --passwords-from-stdin --mysql- ...............

https://i.postimg.cc/8C2nbz5z/Screen-Shot-2021-10-14-at-8-46-11-am.png

How to repeat:
follow the above steps

Suggested fix:
coping this file works for me

source: Applications/MySQLWorkbench.app/Contents/Frameworks/libmysqlclient.21.dylib

target: Applications/MySQLWorkbench.app/Contents/Frameworks/libmysqlclient.dylib
[19 Oct 12:40] MySQL Verification Team
Hello Cesar Ramos,

Thank you for the bug report.
Imho this is duplicate of Bug #103986, please see Bug #103986.

Regards,
Ashwini Patil