Bug #104861 password in MySQL user account creation unable to accept " or '
Submitted: 8 Sep 0:38 Modified: 13 Sep 12:57
Reporter: Chern Wang Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:8.0.26 OS:Microsoft Windows
Assigned to: CPU Architecture:x86

[8 Sep 0:38] Chern Wang
Description:
I was unable to use passwords containing " or ' symbols in the password and confirm password fields of MySQL user credentials in user account creation, during MySQL server installation

However if the password was created manually after installation, " or ' is acceptable.

How to repeat:
Install MySQL into a Windows 10 system, provide a root password, create a new user account, and then enter a password containing " or ' symbols into the password and confirm password fields. The installer will enter many extra symbols into the password field in addition to what was pasted.

This issue was around for a long time already.
[13 Sep 12:57] MySQL Verification Team
Hello Chern Wang,

Thank you for the bug report.
Imho this is duplicate of Bug #95352, please see Bug #95352.

Regards,
Ashwini Patil