Bug #104586 Crash when attempting to alter table
Submitted: 10 Aug 23:16 Modified: 16 Aug 1:50
Reporter: Peter Savarese Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.26 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[10 Aug 23:16] Peter Savarese
Description:
Working with my DB I can alter any other table, however one table named 'player_data' will causes MySQL Workbench to crash whether I click on the wrench or if I right click and click "Alter table". I tried updating from 8.0.25 to 8.0.26 but the crash persists. The crash log is below with debug level 3 enabled.

Unhandled Exception: System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at mforms.TreeView.overlay_icon_for_node_clicked(TreeView* , TreeNodeRef* , Int32 )
   at MformsTree.OnMouseDown(MouseEventArgs args)
   at System.Windows.Forms.Control.WmMouseDown(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
   at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   at MySQL.GUI.Workbench.Program.Main(String[] Args)

How to repeat:
Unsure. I can alter any other tables but the one table named 'player_data' will crash MySQL workbench
[11 Aug 12:56] MySQL Verification Team
Hello Peter,

Thank you for the bug report.
Could you please provide the table structure to reproduce this issue at our end?

Regards,
Ashwini Patil
[11 Aug 19:38] Peter Savarese
Here is the create table for data structure

CREATE TABLE `player_data` (
   `steamid64` varchar(21) NOT NULL DEFAULT '',
   `in_game_name` varchar(32) DEFAULT '',
   `previous_names` text DEFAULT NULL,
   `last_seen` bigint(20) DEFAULT 0,
   `ip` varchar(16) DEFAULT '',
   `points` bigint(20) DEFAULT 0,
   `pointshop_data` longtext CHARACTER SET utf8mb4 COLLATE utf8mb4_bin DEFAULT NULL CHECK (json_valid(`pointshop_data`)),
   `dbd_playtime` text DEFAULT NULL,
   `ip_history` longtext CHARACTER SET utf8mb4 COLLATE utf8mb4_bin DEFAULT NULL CHECK (json_valid(`ip_history`)),
   PRIMARY KEY (`steamid64`)
 ) ENGINE=InnoDB DEFAULT CHARSET=utf8
[12 Aug 12:13] MySQL Verification Team
Hello Peter,

Thank you for the details.
I tried to reproduce your issue on windows 10 with MySQL workbench 8.0.26 and tried to alter the provided table but I am not seeing any issues at my end.

Regards,
Ashwini Patil
[12 Aug 12:15] MySQL Verification Team
8.0.26 test results

Attachment: 104586_results.PNG (image/png, text), 122.07 KiB.

[16 Aug 1:50] Peter Savarese
Hello I'm on vacation right now. I'll post further about this when I get home in a week.