Bug #103783 Error Fetching Table List
Submitted: 23 May 2021 18:30 Modified: 17 Sep 2021 13:13
Reporter: Roland Griggs Email Updates:
Status: Verified Impact on me:
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:8.0.25, 8.0.26, 8.0.30 OS:MacOS (Big Sur Version 11.3.1)
Assigned to: CPU Architecture:Any

[23 May 2021 18:30] Roland Griggs
After creating a schema with tables, I am unable to export tables along with the schema. After clicking the "Start Export" button, I get the following error message:

Error Fetching Table List From [schema name] (DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel')

This issue only appears to occur if capital letters are used to create column or table names.

Also, on the Administration - Data Export page, if I highlight the schema I created that contains the tables, no tables appear under the Schema Objects column on the right.

This appears to be the same issue as Bug# 103572 reported on May 4th, but it is marked as "can't repeat", so I am submitting a new bug report and describing the issue in more detail to see if it can be reproduced and fixed.

I know at least three other people having the same issue on MacOS systems, and we can all export schema with tables when using a PC, so it appears to be a Mac-specific issue, though the PC version does not allow you to input capital letters in column and table names.

How to repeat:
1) Create a new schema and add tables to the schema. Important: Capitalize the first letter of column and table names. This issue only appears reproducible when capital letters are used. 

2) After creating the schema and tables, click the "Administration" tab near the top left corner

3) Click "Data Export" under the "Management" section of "Administration"

4) On the new Data Export tab that is generated, check the "Export" box next to the newly created schema. Notice: when the newly created schema is highlighted, no tables will appear under the "Schema Objects" column on the right

5) Select the following check boxes: Dump Stored Procedures and Functions, Dump Events, Dump Triggers, Export to Self-Contained file, Create Dump in a Single Transaction, Include Create Schema. It's likely these do not all need to be checked to reproduce the issue, but these are the conditions under which the issue occurred for me, so I'm including them just in case.

6) Click "Start Export"

Under the "Export Progress" page, an error message will appear on the first line: 

Error Fetching Table List From [Schema name] (DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel')

7) Open the dump file generated during the export. Notice, none of the code associated with the tables from the newly created schema appear in the script. If you click the lightening button to execute the script, the schema will appear under the schema tab, but none of the tables will be included.

When I use lower case letters in the column and table names, I get the same error message, but the tables seem to export without any obvious issues.
[24 May 2021 21:54] Kenneth Skelps
This bug still exists in MySqlWorkbench 8.0 8.0.25 build 788958. Any upper case letters in any table names or the schema name prevents fetching table names for Data Export.  Table names are present in the Schemas panel.
Problem did not exist in earlier versions of MySqlWorkbench.
[16 Sep 2021 2:14] Michael Preiss
same problem here. none of my table names have uppercase, but my schema name does have upper case. i get the exact same error.
[17 Sep 2021 13:13] MySQL Verification Team
Hello Roland Griggs,

Thank you for the bug report.
Observed this issue on Windows 10 with MySQL Workbench 8.0.26.

Ashwini Patil
[28 Sep 2021 0:43] Rodney Pye
I just downloaded and installed version 8.0.26 and seeing the same issue, in my case all my table names are lower case, but my schema name is all caps.  I have 2 questions:
1. will this be fixed in the next version ?
2. I tried renaming my schema from all caps to all lowercase, but I cant seem to do that in the Schema Editor, the schema name is grayed out (protected).
[13 Dec 2021 3:48] Gerson Roldan
I too have a similar issue. 

When attempting to export my schema (written in lowercase) as a dump file when using the export tool, I have no options for tables to select (schema objects). 

When using a test database with the same data, table names(all lowercase both times) and a now lowercase schema name, I was able to export everything without any issues or warnings.
[6 Jan 2022 19:19] Mark Hostettler
Just learning MySQL and setup a local server/database.  I found that if the Schema name contains any upper case characters the export will not show the table names.  I setup a schema with all lower case characters and tables with uppercase characters.  I was able to export this schema as well.  For the Schema with upper case characters I was able to go into the Schema view and select all tables, then send the create to SQL Query to facilitate "duplication" of a schema.
[14 Sep 2022 7:12] MySQL Verification Team
Bug #108260 marked as duplicate of this one.
[15 Sep 2022 6:50] MySQL Verification Team
Bug #103572 marked as duplicate of this one.