Bug #103753 Unable to start/stop local Server with Workbench
Submitted: 20 May 11:41 Modified: 23 May 12:15
Reporter: Christopher Kirchhöfer Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:8.0.23, 8.0.24, 8.0.25 OS:Microsoft Windows (Server 2019 Std. 1809, 10)
Assigned to: CPU Architecture:Any
Tags: freeze, server, start, stop, workbench

[20 May 11:41] Christopher Kirchhöfer
Description:
On a fresh installation of MySQL Server and Workbench, newer Versions of MySQL Workbench are unable to start/stop the server.
This only happens on MySQL Workbench 8.0.23 or newer, 8.0.22 has no issues on the same system.
Starting/Stopping the MySQL Service itself works just fine.
Already tried to run MySQL Workbench as Admin, but still no luck.

How to repeat:
Install MySQL Server 8.0.25 (Configuration: Dedicated Computer during Installation, nothing else changed)
Install MySQL Workbench 8.0.23, 8.0.24 or 8.0.25, depending on which error you want to reproduce.
Open Workbench, connect to local instance, go to Startup/Shutdown and click Stop Server.

On Workbench v.8.0.23:
The following error message pops up:
Could not stop server: argument 2: <class 'TypeError'>: wrong type

On Workbecnh v.8.0.24 and 8.0.25:
Application freezes and is not able to stop the server.
[20 May 11:43] Christopher Kirchhöfer
This is how the startup message looks like in WB when successfully starting/stopping the server with WB v.8.0.22 or lower

Attachment: SuccessfulStartupMessageLog.txt (text/plain), 3.11 KiB.

[23 May 12:15] MySQL Verification Team
Thank you for the bug report.
[24 May 13:20] MySQL Verification Team
Bug #103782 marked as duplicate of this one.