Bug #103715 MySQL restart due to the bug,it is about my_hash_insert issue
Submitted: 17 May 4:09 Modified: 17 May 8:05
Reporter: z yz Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any

[17 May 4:09] z yz
Description:
MySQL server have restart and i have found the below bug message in errorlog:
10:49:28 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

key_buffer_size=16777216
read_buffer_size=262144
max_used_connections=1243
max_threads=5000
thread_count=1117
connection_count=1117
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 2643337 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x2ab54bfd5000
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 2ab5761c5dc0 thread_stack 0x40000
/rdsdbbin/mysql/bin/mysqld(my_print_stacktrace+0x2c)[0xf31e5c]
/rdsdbbin/mysql/bin/mysqld(handle_fatal_signal+0x47b)[0x84532b]
/lib64/libpthread.so.0(+0xf100)[0x2aaf089e2100]
/rdsdbbin/mysql/bin/mysqld(my_hash_insert+0x393)[0xf13113]
/rdsdbbin/mysql/bin/mysqld(_ZN11Query_cache11store_queryEP3THDP10TABLE_LIST+0x3d8)[0xcaf2f8]
/rdsdbbin/mysql/bin/mysqld(_Z12handle_queryP3THDP3LEXP12Query_resultyy+0x1f9)[0xd394c9]
/rdsdbbin/mysql/bin/mysqld[0x8108c2]
/rdsdbbin/mysql/bin/mysqld(_Z21mysql_execute_commandP3THDb+0x4d52)[0xcfbe22]
/rdsdbbin/mysql/bin/mysqld(_Z11mysql_parseP3THDP12Parser_state+0x37d)[0xcfe5fd]
/rdsdbbin/mysql/bin/mysqld(_Z16dispatch_commandP3THDPK8COM_DATA19enum_server_command+0xab1)[0xcff1e1]
/rdsdbbin/mysql/bin/mysqld(_Z10do_commandP3THD+0x283)[0xd00e13]
/rdsdbbin/mysql/bin/mysqld(handle_connection+0x288)[0xdbfc18]
/rdsdbbin/mysql/bin/mysqld(pfs_spawn_thread+0x159)[0x12ead59]
/lib64/libpthread.so.0(+0x7dc5)[0x2aaf089dadc5]
/lib64/libc.so.6(clone+0x6d)[0x2aaf08ce5c9d]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (2ab54a49f030): SELECT id, entity_type, entity_id, user_id, `action`, details, actor_id, actor_type,create_time,update_time FROM student_app_action_records WHERE id = 47206955
Connection ID (thread ID): 6585565
Status: NOT_KILLED

The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

i guess it is due to the my_hash_insert issue, but not sure

How to repeat:
Not sure yet.
[17 May 5:13] z yz
version is 5.7.26
[17 May 8:05] MySQL Verification Team
Thank you for the bug report. To process this bug report it's necessary a repeatable test and you are reporting a quite older version 5.7.26, please check with current released version 5.7.34.