Bug #103674 SQL Script Generator adds 'b's to subsequent columns
Submitted: 13 May 0:06 Modified: 24 Jun 21:02
Reporter: Brian Eng Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.24 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[13 May 0:06] Brian Eng
Description:
When inserting a new row, if setting a bit(1) column followed by non-bit columns, the script generator will erroneously prepend 'b' for all of the remaining columns, regardless of the column definition 

How to repeat:
Create a table with a bit(1) column followed by varchar(255) columns and add rows
In Navigator, Schemas, right-click on the table, Select Rows
Enter data for a new row, setting the bit(1) column and one or more of the varchar(255) columns, Apply
Expected:
  INSERT INTO statement will have …, b’1’,’0.035’,’100kHz’,’Shielded’);
  'Apply' will succeed
Actual:
  INSERT INTO statement has …, b’1’,b’0.035’,b’100kHz’,b’Shielded’);
  'Apply' fails with 1064: You have an error in your SQL syntax
[13 May 0:07] Brian Eng
Message log

Attachment: image.png (image/png, text), 103.52 KiB.

[13 May 5:36] MySQL Verification Team
Hello Brian Eng,

Thank you for the report and feedback.
Imho this is duplicate of Bug #99585, please see Bug #99585.
Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

regards,
Umesh
[24 Jun 21:02] Brian Eng
I agree that this is a dup of Bug #99585.