Bug #103637 MySQL Linux ODBC Driver crash
Submitted: 10 May 10:33 Modified: 10 May 15:29
Reporter: Yuwei Yang Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:8.0 OS:Linux
Assigned to: CPU Architecture:Any

[10 May 10:33] Yuwei Yang
Description:
Hi team, 

We caught a Driver crash in a customer environment. Here's the detailed log:

[0] /usr/lib64/libc-2.28.so + 0x2f9bc
sp=0x7effe7383520 bp=0
[1] /usr/lib64/libmyodbc8w.so + 0x79716
[2] /usr/lib64/libmyodbc8w.so + 0x795ea
[3] /opt/MicroStrategy/lib/libodbc.so + 0x1bd87e
[4] /opt/MicroStrategy/lib/libodbc.so + 0xe26d2
[5] /usr/lib64/libmyodbc8w.so + 0x7d211
[6] /usr/lib64/libmyodbc8w.so + 0x7ecbd
[7] /usr/lib64/libmyodbc8w.so + 0x7ed28
[8] /opt/MicroStrategy/lib/libodbc.so + 0xe26eb
[9] /usr/lib64/libc-2.28.so + 0xb718
[10] /opt/MicroStrategy/lib/libodbcinst.so + 0x88323
[11] /usr/lib64/libpthread-2.28.so + 0x10d2d
[12] /opt/MicroStrategy/lib/libodbc.so + 0x151b10
[13] /opt/MicroStrategy/lib/libodbc.so + 0x1bf8cb
[14] /opt/MicroStrategy/lib/libodbc.so + 0x151568

I attached the mini core to this bug. Could you please take a look and suggest what's wrong?

Thanks!

How to repeat:
This crash issue is reported by the same customer as #103344.  
We got and loaded the mini core but don't get anything useful. Also can not sure if it's duplicated with that bug.
[10 May 15:29] MySQL Verification Team
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=103344.