Bug #103262 partial Spatial Data Types not support big endian WKB
Submitted: 9 Apr 10:54 Modified: 12 Apr 13:10
Reporter: Mark Simonyi Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: GIS Severity:S3 (Non-critical)
Version:8.0.23 OS:Any
Assigned to: CPU Architecture:Any
Tags: Spatial Data Types, wkb

[9 Apr 10:54] Mark Simonyi
Description:
below Spatial Data Types Spatial not support big endian WKB:
MULTI_POINT,
MULTI_LINE_STRING,
MULTI_POLYGON,
GEOMETRY_COLLECTION

How to repeat:
use below data type big endian WKB update column:
MULTI_POINT,
MULTI_LINE_STRING,
MULTI_POLYGON,
GEOMETRY_COLLECTION

Suggested fix:
hope support big endian WKB for below Spatial Data Types
MULTI_POINT,
MULTI_LINE_STRING,
MULTI_POLYGON,
GEOMETRY_COLLECTION
[12 Apr 13:10] MySQL Verification Team
Hi Mr. Simonyi,

Thank you for your bug report.

How ever this is report is a duplicate of the very well known problem, which is planned to be fix in this WorkLog entry:

https://dev.mysql.com/worklog/task/?id=1076

We do not know yet when will this WorkLog task be scheduled.

We do have one small question for you. Since you are using macOS X, which CPU do you have and is it M1. In the case it is M1, can you share with us how have you built our package. Thanks in advance.