Bug #103198 MySQL Workbench - Migration Bug
Submitted: 3 Apr 14:17 Modified: 6 Apr 12:53
Reporter: Alisson Linneker Alisson Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Migration Severity:S1 (Critical)
Version:8.0.22 OS:Mac OS X (v11.2.3)
Assigned to: CPU Architecture:Any

[3 Apr 14:17] Alisson Linneker Alisson
Description:
When starting the "Determine number of rows to copy" process in the "Bulk Data Transfer" step, the program connects to the Source Server using the Target Server's MySQL port instead of using its own port.

How to repeat:
When starting the "Determine number of rows to copy" process in the "Bulk Data Transfer" step, the program connects to the Source Server using the Target Server's MySQL port instead of using its own port.

Suggested fix:
Confirm that the port variable is not being overwritten, as they are different ports on different servers.
[4 Apr 15:28] Alisson Linneker Alisson
I noticed that direct TCP connection the problem does not occur.

The problem occurred when Source Serve was connected via SSH with a certificate. I made the direct connection and the problem was solved.
[6 Apr 12:53] MySQL Verification Team
Hello,

Thank you for the bug report.
Imho this is duplicate of Bug #100409, please see Bug #100409.

Regards,
Ashwini Patil