Bug #103119 All work lost
Submitted: 26 Mar 6:59 Modified: 29 Mar 12:58
Reporter: Ashish Rawat Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.3.10 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[26 Mar 6:59] Ashish Rawat
Description:
My all work (Queries) lost due to unexpected turning off of my laptop. On restart, while opening My SQL workbench editor, It is unable to restore my previous content. Scratch files in sql_workspaces are blank. I have lost huge amount of data due to my assurance over this auto saving nature of workbench.

 

How to repeat:
While working on workbench > System turning off due to battery exhaust/power failure > Restart > Boom

Suggested fix:
Any method or way to recover my lost data
[26 Mar 7:00] Ashish Rawat
Log file

Attachment: wb.log (application/octet-stream, text), 7.52 KiB.

[26 Mar 7:01] Ashish Rawat
Screen

Attachment: unable to restore.jpg (image/jpeg, text), 17.88 KiB.

[29 Mar 12:58] MySQL Verification Team
Thank you for taking the time to report a problem.  

Unfortunately you are not using a current version of the product you reported a problem with -- the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/

If you are able to reproduce the bug with one of the latest versions, please change the version on this bug report to the version you tested and change the status back to "Open".  

Again, thank you for your continued support of MySQL.