Bug #103089 Can not compile with enable UNIV_IBUF_COUNT_DEBUG
Submitted: 24 Mar 8:56 Modified: 26 Mar 15:22
Reporter: haiqing sun Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:8.0.21 OS:Any
Assigned to: CPU Architecture:Any

[24 Mar 8:56] haiqing sun
Description:
Currently, I can not compile the MySQL by source code with enabling UNIV_IBUF_COUNT_DEBUG, it will be encountering the following errors:

storage/innobase/ibuf/ibuf0ibuf.cc:4683:53: error: no matching function for call to ‘page_id_t::page_id_t(spac
e_id_t&, page_no_t&, int)’
       ulint count = ibuf_count_get(page_id_t(i, j, 0));

How to repeat:
Enable UNIV_IBUF_COUNT_DEBUG
[26 Mar 13:44] MySQL Verification Team
Hi Mr. sun,

Thank you for your bug report.

However, in order to proceed with processing of your report we need additional information from you.

We need detailed info on the OS, its version and version of system library, versions of CMake, C, C++, linker, all of  your CMake settings  and other relevant info.

Last, but not least, you should try using MySQL 8.0.24, since  8.0.21 is an old release.

Only then can we proceed further.
[26 Mar 15:22] MySQL Verification Team
Hi Mr. sun,

Actually, this flag is not used at all.

In the source code it is wrapped within:

#if 0

#endif

conditional compilation block.

Hence, simply do not enable this flag.