Bug #102966 Table Data Export Wizard unresponsive after exporting table data to csv
Submitted: 15 Mar 1:36 Modified: 21 Apr 12:30
Reporter: john walker Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:8.0.23.365764 OS:Microsoft Windows (Windows Server 2019 Datacenter)
Assigned to: CPU Architecture:Any

[15 Mar 1:36] john walker
Description:
Hi, I have an AWS environment with MySQL Community running in Amazon RDS. I installed MySQL Workbench on a Windows EC2 instance within the VPC containing the DB. I can connect to the database with MySQL Workbench, including exporting the table to csv. The issue is that MySQL Workbench interface becomes unresponsive and hangs at where it mentions "The following tasks will now be performed. Please monitor the execution", so it doesn't give any updates. The data however seems to be successfully exported after a while when I check the csv generated.

The table data is around 8 million rows with data similar to:

code,id,sequence
8fbe8d800420d12,8915,1
8fbe8d800420d13,8915,0
8fbe8d800420d16,8915,2
...

Thanks for any help.

How to repeat:
Using Table Data Export Wizard in an AWS environment where the DB resides on Amazon RDS. An EC2 instance within the same VPC with MySQL Workbench installed on Windows is used to export this data.
[21 Apr 12:30] MySQL Verification Team
Hello john walker,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with workbench 8.0.23 but I am not seeing any issues at my end. 

Regards,
Ashwini Patil