Bug #102642 Error 1210 - “Incorrect arguments to mysqld_stmt_execute"
Submitted: 18 Feb 12:58 Modified: 19 Feb 15:15
Reporter: D O Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.7 OS:Ubuntu (20.04)
Assigned to: CPU Architecture:Any

[18 Feb 12:58] D O
Description:
Our product uses docker for distribution. One of the docker containers connects to the MySQL database 5.7 running in another docker container. We have been using Ubuntu 16.04 with libmysqlclient-dev v5.7.26. 

Recently we were forced to upgrade the operating system to Ubuntu 20.04 which comes by default with libmysqlclient-dev ver 8.0.23. 

With this upgrade we started having issues with queries randomly failing. The error we get is 1210,  “Incorrect arguments to mysqld_stmt_execute QMYSQL3: Unable to execute statement”.

We suspect the query failure happens when we create a row in the table containing a blob column and if the blob is filled.

At the moment upgrading the database version is not a real option, so we continue to use v5.7.

We suspect this might be a bug in MySQL.

Is it safe to use libmysqlclient-dev ver 8.0.23 if the database is MySQL 5.7?

We would appreciate any help or suggestions with regards to the error we see.

How to repeat:
We suspect the query failure happens when we create a row in the table containing a blob column and if the blob is filled.
[19 Feb 13:34] MySQL Verification Team
Hi Mr. O,

Thank you for your bug report.

However, this is not a bug. Simply, we do not maintain exactly the same definitions of our C API between different versions.

Hence, if you have used include files from 5.7, or some binary is built with 5.7 libmysqlclient, it will not work with libmysqlclient from version 8.0.

Not a bug.
[19 Feb 15:15] D O
Thank you for looking into this issue for us. We understand from your answer that this is an incompatibility issue caused by mixing 5.7 and 8.0 entities. Although we agree with this, there is something we do not fully understand and we would like to get your view on. On our end we noted, as a workaround, that if we retry executing statements when we got error 1210, subsequent retries seem to work. Would it be possible to please re-open the bug and provide more information on why the workaround described above succeeds?
[19 Feb 15:22] MySQL Verification Team
Hi Mr. O,

What you describe is an installation which has more than one shared library version. It depends on how the OS handles this situation. 

In any case, this is not our bug. What you are asking are the questions pertaining to MySQL support. Hence, please read carefully the following message.
[19 Feb 15:22] MySQL Verification Team
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.

For details on getting support for MySQL products see http://www.mysql.com/support/
You can also check our forums (free) at http://forums.mysql.com/

Thank you for your interest in MySQL.