Bug #102640 ODBC Connector ssl3_get_record:wrong version number
Submitted: 18 Feb 10:33 Modified: 22 Mar 12:31
Reporter: Trevor White Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version: OS:Microsoft Windows (Windows Server 2012 R2 (Build 9600))
Assigned to: CPU Architecture:Any

[18 Feb 10:33] Trevor White
Description:
When connecting from Windows 2012 R2 to MySQL Server Running on Ubuntu 20.04 LTS (8.0.23-0ubuntu0.20.04.1) the ODBC refuses to connect giving the error:

[MySQL][ODBC 8.0(w) Driver]SSL connection error: error: 1408F10B:SSL
routines: ssl3_get_record: wrong version number

If the MySQL server is started up with "skip_ssl" the connection still does not work.

How to repeat:
Install Ubuntu Server 20.04 LTS and patch to the latest version
Install mysql-server
Install Windows Server 2012 R2 (Build 9600)
Install MySQL ODBC Connector 8.00.22
Copy client-key.pem and client-cert.pem from /var/lib/mysql to a folder on the windows machine

Add a user to the Server:
CREATE USER 'ssluser'@'%' IDENTIFIED BY 'SOMESECURE' REQUIRE SSL;
GRANT ALL ON `openitcockpit`.* TO 'ssluser'@'%';
FLUSH PRIVILEGES;

Add new connection to Server, Under SSL, reference the SSL Key and SSL certificate
Press Test

Error appears

Suggested fix:
Any workaround or fix would be great.
[18 Feb 10:34] Trevor White
Error Screen Capture

Attachment: ODBC Error.png (image/png, text), 6.07 KiB.

[22 Mar 12:31] MySQL Verification Team
Hello Trevor White,

Thank you for the bug report.
Imho this is duplicate of Bug #87121, please see Bug #87121.

Regards,
Ashwini Patil