Bug #102576 MySqlException - Table doesn't exists (database/schema twice)
Submitted: 12 Feb 2021 8:43 Modified: 18 Feb 2021 13:11
Reporter: Varsha Pimpare Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Visual Studio Integration Severity:S3 (Non-critical)
Version: OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[12 Feb 2021 8:43] Varsha Pimpare
Description:
Prereq:

Visual Studio - Microsoft Visual Studio Community 2019, Version 16.8.5
.NET Framework - 4.8.04084
MySQL for Visual Studio - 1.2.9

How to repeat:

Add "New Item" in project -> "ADO.NET Entity Data Model" (EF Designer from database) to create models.

While using DBContext in runtime, it throws 
"[MySqlException (0x80004005): Table 'testdb.testdb.tbl_users' doesn't exist]"

Suggested fix:
I followed below steps to fix it manually:

Close visual studio project
Edit MySqlModel.edmx file in notepad
Replace matches in file, from Schema="testdb" to Schema=""
Save MySqlModel.edmx file
Open visual studio project
Compile Project
Run Application

--------------------
It worked.
[12 Feb 2021 8:45] Varsha Pimpare
Changed bug title
[18 Feb 2021 13:11] MySQL Verification Team
Hello Varsha,

Thank you for the bug report.
Imho this is duplicate of Bug #101236, please see Bug #101236.

Regards,
Ashwini Patil