Bug #102541 MySQL Workbench crashes when changing between databases
Submitted: 9 Feb 10:57 Modified: 10 Feb 13:21
Reporter: IGG t Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.23 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:Any
Tags: crash, workbench

[9 Feb 10:57] IGG t
Description:
I have MySQL Workbench 8.0.23 installed on Windows 10. It is virtually unusable. It crashes almost constantly throughout the day. 

I have various databases installed from 5.5 to 8.0. It happens with all of them.

I open MySQL Workbench and it shows me my list of connections. 
I open a connection to one of them, I run a few queries or I look at the connections etc. 
I close the Window. 
I go to open a connection to another one, but I can't, because workbench has frozen. 
It makes no difference if I leave it for 30 seconds or an hour. It just sits there frozen until I kill workbench and have to re-open it. 

How to repeat:
Open a connection to a database, run a few queries or look at the connections etc.
Close the Window. 
Go to open a connection to another database.

Suggested fix:
Allow me to open connections without having to restart workbench every single time.
[9 Feb 12:08] IGG t
Further to this I have noticed that if I wait for apx 10 seconds after I close each window (e.g. close the window, move the cursor over the title bar, wait for 10 seconds, continue), then around 60% of the time it allows me to continue and open another window. But moving to fast causes Workbench to lock up. 

Obviously this is not ideal as all those 10 seconds add up to quite a bit over time.
[9 Feb 12:27] MySQL Verification Team
Hello,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with workbench 8.0.23 but I am not seeing any issues at my end. 
Which server version are you connecting to?

Regards,
Ashwini Patil
[9 Feb 12:37] IGG t
The majority of my databases are MySQL 5.7 (.28 upwards). It also seems to be at it's worst when I:

open a connection the database
open administration > client connections
close administration > client connections
close connection to the database
try and open a different connection
[10 Feb 13:21] MySQL Verification Team
Hello,

Thank you for the feedback.
I tried to reproduce your issue on windows 10 with workbench 8.0.23 connecting to MySQL server 5.7.32 and 5.7.33 and followed exact steps but I am not seeing any issues at my end. 

Regards,
Ashwini Patil