Bug #102504 DEBUG_FRAGMENT_LOCK in production code
Submitted: 6 Feb 18:21 Modified: 17 Mar 16:24
Reporter: Mikael Ronström Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S3 (Non-critical)
Version:8.0.23 OS:Ubuntu
Assigned to: CPU Architecture:Any

[6 Feb 18:21] Mikael Ronström
Description:
The debug define DEBUG_FRAGMENT_LOCK is set also in production code
in 8.0.23. This leads to excessive memory usage, it increases the
memory usage of fragment records by 4 kByte.

How to repeat:
Read code or use sizeof(Fragment record) in DBLQH.

Suggested fix:
Comment away the define in production code.
[7 Feb 6:24] MySQL Verification Team
Hello Mikael,

Thank you for the report and feedback.
Verified as described.

Sincerely,
Umesh
[17 Mar 16:24] Mauritz Sundell
Duplicate of
Bug#102472 DEBUG_FRAGMENT_LOCK active in any build including release build