Bug #102382 Users and Privileges Page Not Working
Submitted: 26 Jan 21:27 Modified: 1 Feb 5:29
Reporter: Sam Beard Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:8.0.23 OS:Microsoft Windows (Windows 10 Pro)
Assigned to: CPU Architecture:Any

[26 Jan 21:27] Sam Beard
Description:
Users and Privileges page has all tabs disabled when connected to DB version 5.6.39-1+7.1-log((Debian)).  Users could be selected, "Details for account xxx" changed but was greyed out and all tabs were greyed out.

When connected to 5.7 DBs there was no issue.

User has GRANT ALL PRIVILEGES ON *.* WITH GRANT OPTION

The only errors in the log are initial login attempts with PASSWORD NO, a warning about a duplicate plugin and the error "Unable to create db_mgmt_SSHConnectionRef object" which looks a little suspicious.

The log I will attach shows attaching to multiple databases and database versions including a 5.5 DB (not supported) the simeon-a database is the one with the issue.  

Reloaded Workbench 8.0.19 and there are no issues

How to repeat:
Connect WB 8.0.23 to DB 5.6.39 and try to use Users and Privileges
[27 Jan 6:42] MySQL Verification Team
Hello Sam Beard,

Thank you for the bug report.
Could you please provide screenshot of the issue? Thanks.

Regards,
Ashwini Patil
[29 Jan 17:23] Sam Beard
I am unable to get that screen shot right now.

I uninstalled the new version and reinstalled 8.0.19 which I had been previously using successfully.

Next week I may be able to reload the new release and try again.

Sam
[1 Feb 5:29] MySQL Verification Team
Hello Sam,

Thank you for the details. 
I tried to reproduce your issue on windows 10 with workbench 8.0.23 but I am not seeing any issues at my end. 

Regards,
Ashwini Patil