Bug #102314 MySqlWorkbench cannot launch on Mac OS Big Sur
Submitted: 20 Jan 14:21 Modified: 20 Jan 14:40
Reporter: Huining Luo Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:8.0.23 OS:Mac OS X (Big Sur)
Assigned to: CPU Architecture:Any

[20 Jan 14:21] Huining Luo
Description:
I am experiencing a technical problem when I installing the MySqlWorkbench software on my Macbook. After I installed it and tried to open it, it always could not launch, and there was an error report. I have deleted the software and installed it again, but it still does not work.

Process:               MySQLWorkbench [3736]
Path:                  /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
Identifier:            com.oracle.workbench.MySQLWorkbench
Version:               8.0.23.CE (1)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           MySQLWorkbench [3736]
User ID:               502

Date/Time:             2021-01-20 14:18:28.645 +0000
OS Version:            macOS 11.1 (20C69)
Report Version:        12
Anonymous UUID:        A54C080A-A035-57C0-D082-5788DB807B2D

Sleep/Wake UUID:       73CD6F83-43AD-4240-A2C4-1C7B04BE1E63

Time Awake Since Boot: 19000 seconds
Time Since Wake:       3000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Abort trap: 6
Termination Reason:    Namespace SIGNAL, Code 0x6

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff20360792 __abort_with_payload + 10
1   libsystem_kernel.dylib        	0x00007fff203621d9 abort_with_payload_wrapper_internal + 80
2   libsystem_kernel.dylib        	0x00007fff20362189 abort_with_reason + 19
3   Python3                       	0x000000010cd21f05 fatal_error.cold.1 + 21
4   Python3                       	0x000000010cca4f78 fatal_error + 536
5   Python3                       	0x000000010cca441a Py_InitializeEx + 138
6   libgrt.dylib                  	0x00000001097da422 grt::PythonContextHelper::InitPython() + 16
7   libgrt.dylib                  	0x00000001097da65e grt::PythonContext::PythonContext(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&) + 412
8   libgrt.dylib                  	0x00000001097c3549 grt::init_python_support(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&) + 38
9   libwbpublic.be.dylib          	0x0000000109b3c71e bec::GRTManager::init_loaders(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&, bool) + 28
10  libwbpublic.be.dylib          	0x0000000109b3c6d4 bec::GRTManager::init_module_loaders(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&, bool) + 102
11  libwbpublic.be.dylib          	0x0000000109b3b635 bec::GRTManager::initialize(bool, std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&) + 55
12  libwbprivate.be.dylib         	0x000000010a45ac55 wb::WBContext::init_(wb::WBFrontendCallbacks*, wb::WBOptions*) + 3517
13  libwbprivate.be.dylib         	0x000000010a4864b5 wb::WBContextUI::init(wb::WBFrontendCallbacks*, wb::WBOptions*) + 435
14  com.oracle.workbench.MySQLWorkbench	0x00000001095b912a -[WBMainController setupBackend] + 1263
15  com.oracle.workbench.MySQLWorkbench	0x00000001095bc7b0 -[WBMainController awakeFromNib] + 428
16  com.apple.CoreFoundation      	0x00007fff204604c9 -[NSSet makeObjectsPerformSelector:] + 231
17  com.apple.AppKit              	0x00007fff22c65a48 -[NSIBObjectData nibInstantiateWithOwner:options:topLevelObjects:] + 1368
18  com.apple.AppKit              	0x00007fff22c5a128 loadNib + 392
19  com.apple.AppKit              	0x00007fff22c59730 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:options:withZone:ownerBundle:] + 693
20  com.apple.AppKit              	0x00007fff22c59386 -[NSBundle(NSNibLoading) loadNibNamed:owner:topLevelObjects:] + 201
21  com.apple.AppKit              	0x00007fff22c59164 +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 394
22  com.apple.AppKit              	0x00007fff22c4bcf8 NSApplicationMain + 566
23  libdyld.dylib                 	0x00007fff2038e621 start + 1

How to repeat:
repeat every time

Suggested fix:
what should I do?
[20 Jan 14:25] Huining Luo
error report

Attachment: error report.docx (application/vnd.openxmlformats-officedocument.wordprocessingml.document, text), 40.60 KiB.

[20 Jan 14:40] MySQL Verification Team
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=102284.