Bug #102286 MySQLWorkbench quit unexpectedly on launch
Submitted: 18 Jan 23:45 Modified: 16 Mar 16:58
Reporter: Christopher Wagner Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:8.0.23 OS:Other (macOS 11.1)
Assigned to: CPU Architecture:Any

[18 Jan 23:45] Christopher Wagner
Description:
I have downloaded the MySQL Community Server 8.0.23 DMG macOS 10.15 (x86, 64-bit), DMG Archive as well as MySQL Workbench 8.0.23 macOS (x86, 64-bit), DMG Archive for both my Macbook Air running on macOS 11.1 Big Sur and my iMac running version 11.1 Big Sur.

MySQL is showing active in my system preferences, however, when I click on the application icon the application never loads and immediately throws an error indicating: MySQLWorkbench quit unexpectedly.

Within the crash report, the following termination information was included:

Crashed Thread:        0  Dispatch queue: com.apple.main-thread
Termination Signal:    Abort trap: 6
Termination Reason:    Namespace SIGNAL, Code 0x6

How to repeat:
1) Download the DMG files as mentioned above on the two systems mentioned

2) Click on the desktop icon to open MySQL Workbench

3) Error populates

Suggested fix:
I spoke with Apple Support and they cannot find anything wrong on their end.  They suggested reaching out to MySQL developers
[19 Jan 0:23] Lexi Rodriguez
I am also having this same exact issue. I have never downloaded this before. I am on my Macbook Pro and using MacOS Big Sure version 11.1
[19 Jan 6:12] MySQL Verification Team
Hello Christopher,

Thank you for the report and feedback.
Verified as described.

regards,
Umesh
[19 Jan 11:00] Rafael Malheiros
Same Problem here Macbook Pro 2020 macOS 11.1
[19 Jan 19:53] Hamish Good
I am also experiencing the same issue. I do not have the MySQL Database installed locally only MySQL Workbench 8.0.23. Initially, after installation I received the usual security pop-ups and these were cleared using the action in Preferences -> Security and Privacy. Once those are cleared the application never opens but crashes a few seconds after execution.
[21 Jan 18:42] Lexi Rodriguez
Has anyone gotten this fixed? I am still having the issue.
[22 Jan 18:51] Andrew Barilla
Can reproduce with 8.0.23 on 11.1. 8.0.22 does launch successfully
[25 Jan 20:48] Danielle C
Thank you Andrew! I experienced the same with 8.0.23 on Mac OS 10.15.16 but then downloaded 8.0.22 and it does launch successfully
[29 Jan 19:08] Michael Homa
On my iMac with MacOS 11.1 Big Sur, I was able to install and launch the MySQL Community Server 8.0.23 from  mysql-8.0.23-macos10.15-x86_64.dmg without any issue.  
I installed MySQL Workbench 8.0.23 from mysql-workbench-community-8.0.23-macos-x86_64.dmg, but was unable to open the app.  The error box said “MySQL Workbench.app can’t be opened because Apple cannot check it for malicious software.”  

Clicking OK did NOT provide me an option to grant an exception for a blocked app by clicking the Open Anyway button in the General pane of Security & Privacy preferences as Apple Support articles described. This button is supposed to appear and be available for about an hour after you try to open the app.  In my case, the button never appeared. 
I attempted thru the Terminal to delete the quarantine with the commands xattr -d com.apple.quarantine <app-path> and sudo spctl —master-disable. This caused MySQLWorkbench to crash on opening, but I didn't get the warning box about malicious software.  I reset things with the command   sudo spctl —master-enable and removed the Workbench 8.0.23 app. 

I saw a comment in the MySQL Forum https://forums.mysql.com/read.php?152,694334,694334#msg-694334 regarding Workbench 8.0.23 not opening on the new Mac M1, reporting that version 8.0.22 would run.  My iMac is not of the M1 variety, but I downloaded and installed  Workbench 8.0.22 from mysql-workbench-community-8.0.22-macos-x86_64.dmg.  

After installation I started the Workbench 8.0.22 app, received the malicious software message, opened the General pane of Security & Privacy preferences, and was presented with an option to Open Anyway, exactly as described in the following Apple Support articles.

https://support.apple.com/en-us/HT202491

https://support.apple.com/guide/mac-help/open-a-mac-app-from-an-unidentified-developer-mh4...
[8 Feb 11:03] MySQL Verification Team
Bug #102527 marked as duplicate of this one
[15 Feb 15:53] WANG KEVIN
Same Issue.

Process:               MySQLWorkbench [6211]
Path:                  /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
Identifier:            com.oracle.workbench.MySQLWorkbench
Version:               8.0.23.CE (1)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           MySQLWorkbench [6211]
User ID:               501

Date/Time:             2021-02-15 23:20:29.292 +0800
OS Version:            Mac OS X 10.15.7 (19H524)
Report Version:        12
Bridge OS Version:     5.2 (18P4346)
[19 Feb 10:10] Domenico Aiello
Switching to the 8.0.22 version solved the problem. The 8.0.23 crashes when launched.
[22 Feb 22:36] J Quigley
I am running MySQL workbench 8.0.22 on Mac Big Sur.  I can open the application, and 'Test Connection', that all works fine.  However, when I attempt to connect to a database, it crashes.  I have also tried 8.0.23, with the same issues.  The database I am trying to connect to is running MySQL 8.0.21.  I have been having this issue since 'upgrading' (haha) to Big Sur a few months ago, impossible to work with.
[1 Mar 22:12] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=102773 marked as duplicate of this one.
[7 Mar 16:56] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=102845 marked as duplicate of this one.
[16 Mar 16:58] Christine Cole
Fixed as of the upcoming MySQL Workbench 8.0.24 release, and here's the proposed changelog entry from the documentation team:

Workbench 8.0.23 closed unexpectedly after starting on macOS systems. This
fix adds the Python 3.7 framework as a prerequisite  for the installation.

Thank you for the bug report.
[4 Apr 23:33] Alisson Linneker Alisson
If you are having a problem, why not disable this version 8.0.23? Even without following security, the app does not open.

When will version 8.0.24 be available?
[17 Apr 19:56] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=103353 marked as duplicate of this one.
[4 May 1:40] Leah Gardner
I had the same error code as mentioned above. It actually ended up affecting my entire laptop, MacBook Pro macOS Big Sur 11.2.3 The bug crashed other programs and messed up my trackpad.

Suggestion from mySQL - call Apple. 
Apples suggestion - Call mySQL, "it's up to  mySQl to update their program and make it current to work with our new IOS." 

What fixed it? Completely losing all my data, to download previous ios. Then deleted and re-downloaded the program.

I hope in the future, this can be resolved without losing data. I would hate for someone to go through what I have, these past 2 months.