Bug #102262 mySQL fails to start
Submitted: 16 Jan 14:20 Modified: 19 Jan 16:24
Reporter: Dick Kaas Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version: OS:Mac OS X (Catalina)
Assigned to: CPU Architecture:x86 (2,3 GHz Quad-Core Intel Core i7)
Tags: 2020, Apple, macbook, MySQL

[16 Jan 14:20] Dick Kaas
Description:
 I tried to use mySQL on my Macbook 2020 with Catalina 10.15.7 and mySQL 8.0.22
When starting I got the following error
2020-12-16T17:38:11.335979Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2020-12-16T17:38:11.344459Z 0 [ERROR] [MY-000068] [Server] unknown option '--skip-locking'.
2020-12-16T17:38:11.345834Z 0 [ERROR] [MY-010119] [Server] Aborting

It is possible that the error already existed in older versions but I did not use it for some years becaus of the insufficient cpu and memory capacity on my old macbook.

Questions
- what do I wrong (or forget?
- where can I find the instruction that went wrong?[--skip-locking]

Hop you can help me.

Dick

How to repeat:
Get a Macbook (suggested 2020) and install Catalina
[I used a default installation]
Download mySQL as .dmg package and install
start mySQL in Apple System Preferences
the ligth starts with green then goes to red and the pattern repeats
In the error log you wil find the error noticed

Suggested fix:
just repair the script with unknown skip-locking
or make this option available
[19 Jan 16:06] MySQL Verification Team
HI Mr. Kaas,

Thank you for your bug report.

However, this is not a bug.

This option is unavailable for quite some time. Hence, you should change your startup options.

Not a bug.
[19 Jan 16:24] Dick Kaas
MySQL verification team,

I guess it still is a bug. I just downloaded the .dmg file for mySQL and installed it with default parameters. When still not doing anything with my own program and data I got this error so I assume it is in some script that was send together with the .dmg file.
.. or it is generated from within a standard call during the stantup of mySQL

==> otherwise... where can I find this script?

Dick
[20 Jan 12:51] MySQL Verification Team
Hi,

You just have to edit your configuration file, be it my.cnf or .my.cnf ......

Just delete that option ...... If you are using some script, then check whether it is ours. If it is , get the newer version.