Bug #102250 MGR 8.0 periodic performance degradation
Submitted: 15 Jan 3:24 Modified: 18 Jan 12:08
Reporter: ping xia Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Group Replication Severity:S3 (Non-critical)
Version:8.0.22 OS:CentOS (CentOS Linux release 7.5.1804 (Core) )
Assigned to: MySQL Verification Team CPU Architecture:Any

[15 Jan 3:24] ping xia
Description:

32 threads, average tps is 3792, 101s is reduced to 1658, 161s is 1224, about 60s once

How to repeat:
sysbench : 
/usr/bin/sysbench  /usr/share/sysbench/oltp_read_write.lua --db-driver=mysql --events=$events --threads=$threads --time=$time --mysql-host=$host --mysql-user=$user --mysql-password=$password --mysql-port=$port --report-interval=1  --tables=$tables --table-size=$table_size --rate=$rate  --mysql-ignore-errors=all run
[15 Jan 3:26] ping xia
sysbench.log

Attachment: sysbench.log (application/octet-stream, text), 74.99 KiB.

[18 Jan 12:08] MySQL Verification Team
Hi,

Thanks for the report. We are constantly working on improving performance of all our products as there can always be more performance and more consistent performance but this is not a bug. 

kind regards
Bogdan