Bug #102204 performance issues with MySQL and dotnet 5.0
Submitted: 8 Jan 23:47 Modified: 19 Jan 19:37
Reporter: Gustavo Cuatepotzo Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:8.0.22 OS:Any
Assigned to: CPU Architecture:Any

[8 Jan 23:47] Gustavo Cuatepotzo
Description:
I am having performance issues with the MySQL and dotnet 5.0
On a simple query dotnet with

MsSQL gives an execution time of 20ms
MySQL gives an execution time of 515ms

I am using Dapper, however Dapper is not the problem, I have
similar execution without Dapper.
My MySQL instances appears to be in order, and I can
execution the same query with GO in 26ms (or similar what I
get with MsQuery

How to repeat:
My tests and code is found here.
https://bitbucket.org/LarsKlingsten/dotnet5-mysql-performance-problems/src/master/

The repo now has six version (more or less identical) with 2 for each
db driver (2 on MySQL and 1 for MsSQL). There are two version for each
with a version for Dapper and one without

https://bitbucket.org/LarsKlingsten/dotnet5-mysql-performance-problems/src/master/Lib/Data...

The 'readme.md' file has been updated already.
[15 Jan 4:17] Bradley Grainger
This may be a duplicate of bug #101714.
[19 Jan 19:37] Daniel Valdez
Duplicate of 101714