Bug #102148 Cannot access a disposed object - 'HUDForm' from SQLWorkBench
Submitted: 5 Jan 7:56 Modified: 5 Jan 9:58
Reporter: Robert Carroll Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.22 build 107600 CE 64bits Community OS:Microsoft Windows (Win 10, )
Assigned to: CPU Architecture:x86 (64 bit)
Tags: HUDFORM, SQLServer, SQLWorkbench

[5 Jan 7:56] Robert Carroll
Description:
I am a first time user for MySQL. There were multiple issues encountered, not sure if all related so grouping them all together:

NB: Multiple new installs/uninstalls of MySQL 8.0.22 Community (never installed a different version before - first time user):

Issue 1: From MySQL Workbench - Unable to connect to local host:
(NB - In  MS 'Services', the MySQL80 service is NOT running)
1. From MySQL Workbench welcome page, I click on the MySQL Connection that was generated during the install. 
2. Does not ask for password (assume that is because i set that in the install)
3. The SQL Editor page is loaded and defaults to the 'Administration - Server Status', tab.
4. From the SQL Editor 'Administration - Server Status' tab, I expected the server to be started (MySQL80 service) (rightly or wrongly), but it was NOT unable to connect to local host (this could be because MySQL80 service is not running, but not sure - i thought it would start it for me)
5. From Startup / Shutdown MySQL Server (instance is ;stopped;), I click on the 'Start Server' button and enter my root password
6. From the Startup Message Log area, there are messages: 'Unable to connect to localhost (2003) and 'Assuming server is not running'
7. But the 'Database server instance ' is now set to running and the button now reads 'Stop Server'
8. The MSQL80 service is now running
9. But all the messages on the pages still read 'Unable to connect to localhost'
10. While trying to repeat all this to write the details I am now getting a new problem - now when i enter my root password I am getting a new popup error: Cannot connect to database server...

How to repeat:
FYI - I need to reboot pc (yet again) - as i am just getting a whole load of new issues -  so this will need to be a work in progress.  If this defect gets sent please ignore for now as I will need to come back to it and finish it off. I really don't want to have to start over again.
[5 Jan 8:38] Robert Carroll
I am no longer able to get the HUDForm error.  At the point I attempt to 'Start Server' from the Startup / Shutdown MySQL Server' section, it is now failing on the root password and not accepting it.  All the other issues i was having are the same, so i will need to raise another defect.
[5 Jan 9:58] MySQL Verification Team
Hello Robert Carroll,

Thank you for the bug report.
Imho this is duplicate of Bug #100406, please see Bug #100406.

Regards,
Ashwini Patil