Bug #102138 Forward-engineering breaks up by an error
Submitted: 4 Jan 9:00 Modified: 5 Jan 8:52
Reporter: peacecop kalmer tomekit Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:8 OS:Ubuntu (20.04)
Assigned to: CPU Architecture:Any
Tags: forward engineering

[4 Jan 9:00] peacecop kalmer tomekit
Description:
I created a model in "MySQL Workbench" and tried to forward-engineer it which ended by:
"Executing SQL script in server
ERROR: Error 1064: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '
  UNIQUE INDEX `letterNumber_UNIQUE` (`letterNumber` ASC) VISIBLE)
ENGINE = ...' at line 6
SQL Code:
        CREATE TABLE IF NOT EXISTS `tennisMath`.`Court` (
          `idCourt` INT NOT NULL AUTO_INCREMENT,
          `letterNumber` CHAR(2) NOT NULL,
          `surface` ENUM('grass', 'clay') NOT NULL,
          PRIMARY KEY (`idCourt`),
          UNIQUE INDEX `idCourt_UNIQUE` (`idCourt` ASC) VISIBLE,
          UNIQUE INDEX `letterNumber_UNIQUE` (`letterNumber` ASC) VISIBLE)
        ENGINE = InnoDB

SQL script execution finished: statements: 6 succeeded, 1 failed

Fetching back view definitions in final form.
Nothing to fetch"

How to repeat:
Create a data model with a table like my one and try to forward-engineer it into "10.3.25-MariaDB-0ubuntu0.20.04.1 Ubuntu 20.04"!
[4 Jan 13:30] MySQL Verification Team
Hello,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with workbench 8.0.22 using table structure provided but I am not seeing any issues at my end.

Regards,
Ashwini Patil
[4 Jan 17:30] peacecop kalmer tomekit
Have you tried it on "mariadb"?
[5 Jan 7:37] MySQL Verification Team
Please note that server MariaDB isn't supported by MySQL Workbench. Thanks.