Bug #102075 network and server is ok, but GR node been unreachable
Submitted: 26 Dec 2020 9:25 Modified: 28 Dec 2020 15:01
Reporter: ping xia Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Group Replication Severity:S2 (Serious)
Version:5.7.29 OS:CentOS (CentOS Linux release 7.5.1804 (Core) )
Assigned to: CPU Architecture:x86 (Intel(R) Xeon(R) CPU E5-2640 v4 @ 2.40GHz)
Tags: mgr

[26 Dec 2020 9:25] ping xia
Description:
we have 3 Group Replication Node :mysql-01(read/write node ) 、  mysql-02 (backup node ) and  mysql-03 (backup node ). single-primary mode

Suddenly, the primary node and the 2 SECONDARY lose connection, primary,the following information:

2020-12-26T08:30:12.331947+08:00 0 [Warning] Plugin group_replication reported: 'Member with address mysql-02:3406 has become unreachable.'
2020-12-26T08:30:12.331987+08:00 0 [Warning] Plugin group_replication reported: 'Member with address mysql-03:3406 has become unreachable.'
2020-12-26T08:30:12.332020+08:00 0 [ERROR] Plugin group_replication reported: 'This server is not able to reach a majority of members in the group. This server will now block all updates. The server will remain blocked for the next 5
 seconds. Unless contact with the majority is restored, after this time the member will error out and leave the group. It is possible to use group_replication_force_members to force a new group membership.'
2020-12-26T08:30:18.332377+08:00 0 [ERROR] Plugin group_replication reported: 'This member could not reach a majority of the members for more than 5 seconds. The member will now leave the group as instructed by the group_replication_
unreachable_majority_timeout option.'

SECONDARY:mysql-02
2020-12-26T08:31:15.895767+08:00 0 [Warning] Plugin group_replication reported: 'The member with address mysql-02:3406 has already sent the stable set. Therefore discarding the second message.'
2020-12-26T08:31:16.150234+08:00 0 [Warning] Plugin group_replication reported: 'The member with address mysql-03:3406 has already sent the stable set. Therefore discarding the second message.'

But from the monitoring and investigation, the network and SECONDARY nodes are normal

Also analyzed the binglog of this period, no transaction, the largest transaction is only 6067 bytes

How to repeat:
noe
[27 Dec 2020 1:30] ping xia
Happened again online
[28 Dec 2020 12:03] Pedro Pinheiro
Hi,
Do you have VMware of other virtualization i use?
I've seen this issues, during vmotion or VM snapshot.
[28 Dec 2020 15:01] MySQL Verification Team
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=91465.