Bug #101886 select count(*) very slow on windows mysql server
Submitted: 7 Dec 2020 6:50 Modified: 9 Dec 2020 6:21
Reporter: jack jack Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.0.22 OS:Microsoft Windows (win10 professional 2004)
Assigned to: CPU Architecture:x86 (ryzen 4800u ´╝îintel 8600k)
Tags: select count, slow

[7 Dec 2020 6:50] jack jack
Description:
when i connect mysql server for windows on my laptop,  the select count(*) is very slow, so i created 100 thousands rows data, it's runed 13s.i tried most times, always this. the server version is 8.0.22.

but the same data, on server for linux, less than 1s. version is 8.0.22 too.

then i connect mysql server for windows on my desktop, server version is 8.0.11, same data, only 1s, but then upgrade to 8.0.22, it's slow

How to repeat:
connect a mysql server for windows, and makr sure version is 8.0.22. 
run select count(*) from any_table;
[8 Dec 2020 13:11] MySQL Verification Team
Hi Mr. Jack,

Thank you for your bug report.

However, this is not a bug.

A difference in the speed that you see between Windows and Linux with our 8.0.22 release are not due to our code. Simply, LInux has much faster filesystem caching.

To check this , you can try to create all your tablespaces with direct, no cache access. This is available on most filesystems that are available on Linux. This is described in our Reference Manual.

Not a bug.
[8 Dec 2020 13:53] jack jack
but why the 8.0.11 version is faster?
 same pc, i only upgrade to 8.0.22 from 8.0.11 , before upgrade, it's 1s.
 after upgrade, it's 13s,
 so what change in 8.0.22 for windows
[8 Dec 2020 14:03] MySQL Verification Team
Hi,

There are no changes interim ...... could be due to the state of the filesystem cache.
[8 Dec 2020 15:42] jack jack
..ok

i will reinstall older version and test
[9 Dec 2020 6:21] jack jack
i test old version, from 8.0.11 to 8.0.22, the count slow in 8.0.17 version,
so i search result on https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-17.html#mysqld-8-0-17-bug.   i fount Bug #29939617, but i dont know what it's change. so i search commit in github, https://github.com/mysql/mysql-server/search?q=&type=commits, but only the bug29939617 number cannot search anything ...