Bug #101795 slave io_thread error,Relay log write failure: could not queue event from master
Submitted: 30 Nov 2020 7:03 Modified: 3 Dec 2020 2:58
Reporter: Annotations Alerts Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S1 (Critical)
Version:5.7.29-32 OS:CentOS (7.8)
Assigned to: CPU Architecture:x86
Tags: binlog error, slave error

[30 Nov 2020 7:03] Annotations Alerts
Description:
hi,I find my two slaves throw io_thread error "Relay log write failure: could not queue event from master",so i start slave on one of slave.the slave throws the error "Got fatal error 1236 from master when reading data from binary log: 'log event entry exceeded max_allowed_packet; Increase max_allowed_packet on master; the first event '3316-master-binlog.000047' at 1099252825, the last event read from '/data1/3316/logs/binlog/3316-master-binlog.000047' at 123, the last byte read from '/data1/3316/logs/binlog/3316-master-binlog.000047' at 1099252844.'".

So i increase the 'max_allowed_packet' to 1G on master and two slaves,i start slave later, He's still like that.I find the master binlog ‘3316-master-binlog.000047’ is unnormal from 1099252825 when I execute "show binlog events in '3316-master-binlog.000047' from 1099252825 " on master.It throws that "Wrong offset or I/O error". So i execute "show binlog events in '3316-master-binlog.000047",then I get all binlog to rows.

How to repeat:
through binlog,we can know there was two big events as "load data infile"
[30 Nov 2020 7:05] Annotations Alerts
whether there is a problem when pos > end_log_pos
[30 Nov 2020 11:32] MySQL Verification Team
You cannot restart slave from a position > 4G.
See:  https://bugs.mysql.com/bug.php?id=55231
[1 Dec 2020 9:45] Annotations Alerts
hi:
  thanks very much for your reply!
  I can't understand what you say.Can you go into more detail? I want to know that why the all slave io_thread  down at the same time.

thanks,
longfei
[1 Dec 2020 10:02] MySQL Verification Team
Please see the referenced bug for details.

The position 1099252825 is probably bogus in your case.
Correct position might be 1099252825 + (1024*1024*1024*4) .

But you cannot start a slave on such high position because the protocol doesn't support 64-bit numbers.
[1 Dec 2020 15:57] MySQL Verification Team
Duplicate of bug #55231
[3 Dec 2020 2:58] Annotations Alerts
ok,thanks for your reply.