Bug #101741 unable to perform migration
Submitted: 25 Nov 2020 4:19 Modified: 25 Nov 2020 12:25
Reporter: Anil Moolya Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Migration Severity:S1 (Critical)
Version:8.0.22 OS:Microsoft Windows (Microsoft Windows 10 Home Single Language)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[25 Nov 2020 4:19] Anil Moolya
Description:
When migrating from a PostgreSQL 11 instance, Workbench will hard crash on Windows on the "Migration" screen.

How to repeat:
Install Postgres ODBC 64bit drivers, define a System DSN to a Postgres 11 database. Connection test should be successful. 

Open MySQL Workbench > Data Migration

On "Source Selection" screen, Choose PostgreSQL and Connection Method: ODBC Data Source. Select the DSN that you just created.

On "Target Selection" screen, select any MySQL database. I just chose one that I had running, 8.0.22. A standard TCP/IP connection, didn't bother setting up ODBC for it.

You should be able to flip through the next few screens by accepting default settings.

When you get to the "Migration" screen, `Migrate Selected Objects` will succeed, but `Generate SQL CREATE Statements` will cause MySQL Workbench to crash. Windows will tell you that MySQL Workbench has stopped working.
[25 Nov 2020 12:25] MySQL Verification Team
Hello Anil Moolya,

Thank you for the bug report.
This is most likely duplicate of Bug #93594, please see Bug #93594.
Even if you feel that your issue is somewhat different, the resolution is likely to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Regards,
Ashwini Patil