Bug #101710 Add NULL value
Submitted: 22 Nov 2020 18:13 Modified: 25 Nov 2020 12:20
Reporter: Andrey Saulin Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.16 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:x86
Tags: WBBugReporter

[22 Nov 2020 18:13] Andrey Saulin
Description:
When add NULL value in Worbench to any field record in result grid value 
decorate with quotes and this approach emit error in apply form for any types differ from varchar. 

How to repeat:
See Description 

Suggested fix:
You need aplly NULL value without quotes
[24 Nov 2020 10:48] MySQL Verification Team
Hello Andrey Saulin,

Thank you for the bug report.
Could you please provide the table structure and screenshot illustrating this issue?

Regards,
Ashwini Patil
[25 Nov 2020 6:34] Andrey Saulin
model

Attachment: WBUsers.JPG (image/jpeg, text), 79.20 KiB.

[25 Nov 2020 6:34] Andrey Saulin
input NULL in integer field

Attachment: inputNULLinInteger.JPG (image/jpeg, text), 32.47 KiB.

[25 Nov 2020 6:35] Andrey Saulin
quots in expression

Attachment: applyform.JPG (image/jpeg, text), 21.29 KiB.

[25 Nov 2020 6:36] Andrey Saulin
error

Attachment: error.JPG (image/jpeg, text), 45.66 KiB.

[25 Nov 2020 6:36] Andrey Saulin
Applyed attachments
[25 Nov 2020 12:20] MySQL Verification Team
Hello Andrey Saulin,

Thank you for the requested details.
Imho this is not a bug. You need to set NULL values by right clicking on the field and click "Set Field to NULL" option.

Regards,
Ashwini Patil