Bug #101632 Starting... Connect to source DBMS... - Connecting... Connecting to ... Opening
Submitted: 16 Nov 2020 22:03 Modified: 18 Nov 2020 11:44
Reporter: Marius Apriutesa Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Migration Severity:S3 (Non-critical)
Version:8.0.21 OS:Microsoft Windows (Microsoft Windows 10 Home)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[16 Nov 2020 22:03] Marius Apriutesa
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\Marius\AppData\Roaming\MySQL\Workbench\log\wb.log]
Starting...
Connect to source DBMS...
- Connecting...
Connecting to ...
Opening ODBC connection to DSN=instituto_datos_access...
Traceback (most recent call last):
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\db_msaccess_re_grt.py", line 701, in connect
    return MsAccessReverseEngineering.connect(connection, password)
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\db_msaccess_re_grt.py", line 152, in connect
    con = db_driver.connect(connection, password)
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\workbench\db_driver.py", line 95, in connect
    connection = library.connect(connection_string, password=password)
pyodbc.Error: ('HY000', 'The driver did not supply an error!')

Traceback (most recent call last):
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\workbench\wizard_progress_page_widget.py", line 71, in run
    self.func()
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\migration_schema_selection.py", line 172, in task_connect
    if not self.main.plan.migrationSource.connect():
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\migration.py", line 199, in connect
    self._rev_eng_module.connect(self.connection, self.password or "")
SystemError: Error("('HY000', 'The driver did not supply an error!')"): error calling Python module function DbMsAccessRE.connect
ERROR: Error during Connect to source DBMS: Error("('HY000', 'The driver did not supply an error!')"): error calling Python module function DbMsAccessRE.connect
ERROR: Exception in task 'Connect to source DBMS': SystemError('Error("(\'HY000\', \'The driver did not supply an error!\')"): error calling Python module function DbMsAccessRE.connect',)

Failed

How to repeat:
Starting...
Connect to source DBMS...
- Connecting...
Connecting to ...
Opening ODBC connection to DSN=instituto_datos_access...
Traceback (most recent call last):
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\db_msaccess_re_grt.py", line 701, in connect
    return MsAccessReverseEngineering.connect(connection, password)
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\db_msaccess_re_grt.py", line 152, in connect
    con = db_driver.connect(connection, password)
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\workbench\db_driver.py", line 95, in connect
    connection = library.connect(connection_string, password=password)
pyodbc.Error: ('HY000', 'The driver did not supply an error!')

Traceback (most recent call last):
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\workbench\wizard_progress_page_widget.py", line 71, in run
    self.func()
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\migration_schema_selection.py", line 172, in task_connect
    if not self.main.plan.migrationSource.connect():
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\migration.py", line 199, in connect
    self._rev_eng_module.connect(self.connection, self.password or "")
SystemError: Error("('HY000', 'The driver did not supply an error!')"): error calling Python module function DbMsAccessRE.connect
ERROR: Error during Connect to source DBMS: Error("('HY000', 'The driver did not supply an error!')"): error calling Python module function DbMsAccessRE.connect
ERROR: Exception in task 'Connect to source DBMS': SystemError('Error("(\'HY000\', \'The driver did not supply an error!\')"): error calling Python module function DbMsAccessRE.connect',)

Failed

Suggested fix:
Starting...
Connect to source DBMS...
- Connecting...
Connecting to ...
Opening ODBC connection to DSN=instituto_datos_access...
Traceback (most recent call last):
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\db_msaccess_re_grt.py", line 701, in connect
    return MsAccessReverseEngineering.connect(connection, password)
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\db_msaccess_re_grt.py", line 152, in connect
    con = db_driver.connect(connection, password)
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\workbench\db_driver.py", line 95, in connect
    connection = library.connect(connection_string, password=password)
pyodbc.Error: ('HY000', 'The driver did not supply an error!')

Traceback (most recent call last):
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\workbench\wizard_progress_page_widget.py", line 71, in run
    self.func()
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\migration_schema_selection.py", line 172, in task_connect
    if not self.main.plan.migrationSource.connect():
  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\modules\migration.py", line 199, in connect
    self._rev_eng_module.connect(self.connection, self.password or "")
SystemError: Error("('HY000', 'The driver did not supply an error!')"): error calling Python module function DbMsAccessRE.connect
ERROR: Error during Connect to source DBMS: Error("('HY000', 'The driver did not supply an error!')"): error calling Python module function DbMsAccessRE.connect
ERROR: Exception in task 'Connect to source DBMS': SystemError('Error("(\'HY000\', \'The driver did not supply an error!\')"): error calling Python module function DbMsAccessRE.connect',)

Failed
[18 Nov 2020 11:44] MySQL Verification Team
Hello Marius Apriutesa,

Thank you for the bug report.
Imho this is duplicate of Bug #87647, please see Bug #87647.

Regards,
Ashwini Patil