Bug #101487 MySQL Workbench freezes when opening/creating Model
Submitted: 6 Nov 2020 4:58 Modified: 20 Nov 2020 12:49
Reporter: Derek McKinnon Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S7 (Test Cases)
Version:8.0.21 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:x86
Tags: WBBugReporter

[6 Nov 2020 4:58] Derek McKinnon
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\Derek\AppData\Roaming\MySQL\Workbench\log\wb.log]

I was sent a mwb file.  When opening it MySQL Workbench froze.  The file works for several other people

So after restarting MySQL Workbench, I tried to create a mwb file.  When I double click "Add Diagram", the program freezes.  So it is obviously a problem with my computer.

How to repeat:
Problem only occurs on my computer.
[6 Nov 2020 12:13] MySQL Verification Team
Hello Derek McKinnon,

Thank you for the bug report.
Please try 8.0.22 and report us back if issue persist even in latest version along with unaltered error log.

Regards,
Ashwini Patil
[9 Nov 2020 2:19] Derek McKinnon
Log File

Attachment: wb.log (application/octet-stream, text), 8.02 KiB.

[9 Nov 2020 2:20] Derek McKinnon
Thank you for your reply.  I have installed 8.0.22 and the problem is still occurring.  I have attached the log file as requested.

Cheers
Derek
[11 Nov 2020 11:57] MySQL Verification Team
Hello Derek McKinnon,

Thank you for the details.
I tried to reproduce your issue on windows 10 with workbench 8.0.22 using dummy model but I am not seeing any issues at my end.
May I request you to please provide exact model file used in your environment to reproduce this issue at our end?

Regards
Ashwini Patil
[12 Nov 2020 0:59] Derek McKinnon
I do not know what you mean by "exact model file".
[12 Nov 2020 4:37] MySQL Verification Team
"I was sent a mwb file.  When opening it MySQL Workbench froze.  The file works for several other people" -- Please provide the model file which has caused the issue (make it as private if you prefer) . I am not seeing any issues opening/creating a model at my end.
[18 Nov 2020 3:36] Derek McKinnon
I have attached the file.  However given my workbench has the same problem when creating a new file, I don't think the problem is the file, but is my computer.  You will never be able to recreate it as you don't have access to my computer.
[20 Nov 2020 12:49] MySQL Verification Team
Hello Derek McKinnon,

Thank you for the requested details.
I tried to reproduce your issue on windows 10 with workbench 8.0.22 using the file you have shared but I am not seeing any issues at my end.
As you rightly pointed out, this looks one off instance dependent issue and hence not seen at my end and even on colleagues test box. Closing it as can't repeat for now. Thank you!

Regards,
Ashwini Patil