Bug #101484 Foreign keys are not shown in their tab under a table info.
Submitted: 5 Nov 2020 19:37 Modified: 26 Oct 13:13
Reporter: Filippo Landi Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S4 (Feature request)
Version:8.0.22 OS:Linux (Fedora release 33 Thirty Three x86_64)
Assigned to: CPU Architecture:x86
Tags: WBBugReporter

[5 Nov 2020 19:37] Filippo Landi
Description:
----[For better reports, please attach the log file after submitting. You can find it in /home/cippo95/.mysql/workbench/log/wb.log]
Foreign keys are not shown in their tab under a table info.
Trying to refresh in that tab gives: "Unhandled exception:invalid column constraint_name for resultset".

How to repeat:
Foreign keys are not shown in their tab under a table info.
Trying to refresh in that tab gives: "Unhandled exception:invalid column constraint_name for resultset".

Suggested fix:
It should display foreign keys as desired.
[5 Nov 2020 19:38] Filippo Landi
wb.log file

Attachment: wb.log (text/x-log), 6.61 KiB.

[24 Dec 2020 7:46] Peter Stiles
This is happening for us too.

We have a MySql 8.0.22 database, running in Docker (for development) and natively on linux (for test/production).

We experienced this problem when using Workbench 8.0.19 and were hoping the upgrade to workbench 8.0.22 would address the issue but are sad that it has not.

Looking on the "DDL" tab it clearly shows FK constraints against the table, but as per original poster there is simply a blank "Foreign Keys" tab.
[16 May 7:10] Preksha Patel
This is happening to me also. I am using 8.0.24.0.
[15 Jun 7:57] Venkata Rachur
Same issue with 8.0.25
[11 Aug 17:44] Robin Chappatte
Same issue with v. 8.0.26 build 972499 on Ubuntu 20.04 (64 bits)
[26 Oct 13:13] MySQL Verification Team
Hello Filippo Landi,

Thank you for the bug report.
Imho this is duplicate of Bug #102496, please see Bug #102496.

Regards,
Ashwini Patil