Bug #101307 EER Diagram does not update when synchronizing model with database
Submitted: 25 Oct 2020 4:26 Modified: 30 Oct 2020 11:55
Reporter: Barry Chapman Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:8.0.21 OS:Microsoft Windows (10 / 2004 build 19041.572)
Assigned to: CPU Architecture:Other (x86_64)
Tags: EER, synchronization, workbench

[25 Oct 2020 4:26] Barry Chapman
Description:
In a EER diagram with around 40 tables, I was able to migrate the changes to the database correctly.

However, after making some changes on foreign keys and a few tables in the database, we wanted to pull those changes to be reflected in the EER. When synchronizing the EER with the live database, there were no changes reflected in the change list.

https://www.screencast.com/t/X0tvA1FfQ8m

On that note, there seems to be a UI bug below the 'Model and Database Differences' selection box. After querying the database for changes, and then bringing me here - there are no visible changes to report. I click on 'Update Model' at the bottom of the screen, a piece of text appears that says 'Update Source'. 

https://www.screencast.com/t/er9uTlTG

If you click the button that says 'Update Source', the text disappears.

https://www.screencast.com/t/2QZP6aHNhi

Clicking 'Next' takes you to a screen with no visible changes:

https://www.screencast.com/t/qnOdjGlo2W

Thanks

How to repeat:
Create an EER, push the changes to a local database. Update database on the DB view side. Attempt to synchronize the model with the database - observe above behavior.
[30 Oct 2020 11:55] MySQL Verification Team
Hello Barry Chapman,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with workbench 8.0.22 using dummy model but I am not seeing any issues at my end.

Regards,
Ashwini Patil